aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch b/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
new file mode 100644
index 00000000..9a7b8445
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
@@ -0,0 +1,51 @@
+From 48e50f06b1bbed94cdf5207587161d4bfce7366e Mon Sep 17 00:00:00 2001
+From: Naveen Saini <naveen.kumar.saini@intel.com>
+Date: Wed, 21 Aug 2019 14:35:31 +0800
+Subject: [PATCH] llvm-spirv: skip building tests
+
+Some of these need clang to be built and since we're building this in-tree,
+that leads to problems when compiling libcxx, compiler-rt which aren't built
+in-tree.
+
+Instead of using SPIRV_SKIP_CLANG_BUILD to skip clang build and adding this to
+all components, disable the building of tests altogether.
+
+Upstream-Status: Inappropriate
+
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
+---
+ CMakeLists.txt | 10 ----------
+ 1 file changed, 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1208741..20ca3e6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,13 +15,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
+ set(CMAKE_CXX_STANDARD 11)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+- if(LLVM_INCLUDE_TESTS)
+- set(LLVM_TEST_COMPONENTS
+- llvm-as
+- llvm-dis
+- )
+- endif(LLVM_INCLUDE_TESTS)
+-
+ find_package(LLVM 9.0.0 REQUIRED
+ COMPONENTS
+ Analysis
+@@ -56,9 +49,6 @@ set(LLVM_SPIRV_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include)
+
+ add_subdirectory(lib/SPIRV)
+ add_subdirectory(tools/llvm-spirv)
+-if(LLVM_INCLUDE_TESTS)
+- add_subdirectory(test)
+-endif(LLVM_INCLUDE_TESTS)
+
+ install(
+ FILES
+--
+2.17.1
+