aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-sys940x/conf/machine/sys940x-noemgd.conf2
-rw-r--r--meta-sys940x/conf/machine/sys940x.conf2
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend12
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto_3.2.bbappend14
4 files changed, 30 insertions, 0 deletions
diff --git a/meta-sys940x/conf/machine/sys940x-noemgd.conf b/meta-sys940x/conf/machine/sys940x-noemgd.conf
index 537e4196..23ec0bce 100644
--- a/meta-sys940x/conf/machine/sys940x-noemgd.conf
+++ b/meta-sys940x/conf/machine/sys940x-noemgd.conf
@@ -10,6 +10,8 @@ require conf/machine/include/ia32-base.inc
# Add "pcbios" if you have a non-efi version of the firmware
MACHINE_FEATURES += "efi pcbios"
+PREFERRED_VERSION_linux-yocto ?= "3.2%"
+
XSERVER ?= "${XSERVER_IA32_BASE} \
${XSERVER_IA32_EXT} \
${XSERVER_IA32_VESA} \
diff --git a/meta-sys940x/conf/machine/sys940x.conf b/meta-sys940x/conf/machine/sys940x.conf
index 71236534..4b9b91d9 100644
--- a/meta-sys940x/conf/machine/sys940x.conf
+++ b/meta-sys940x/conf/machine/sys940x.conf
@@ -10,6 +10,8 @@ require conf/machine/include/ia32-base.inc
# Add "pcbios" if you have a non-efi version of the firmware
MACHINE_FEATURES += "efi pcbios"
+PREFERRED_VERSION_linux-yocto ?= "3.2%"
+
XSERVER ?= "${XSERVER_IA32_BASE} \
${XSERVER_IA32_EXT} \
${XSERVER_IA32_EMGD} \
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend
new file mode 100644
index 00000000..da239fdd
--- /dev/null
+++ b/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+COMPATIBLE_MACHINE_sys940x = "sys940x"
+KMACHINE_sys940x = "sys940x"
+
+COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
+KMACHINE_sys940x-noemgd = "sys940x"
+
+# Update the following to use a different BSP branch or meta SRCREV
+#KBRANCH_sys940x = "standard/preempt-rt/base"
+SRCREV_machine_pn-linux-yocto-rt_sys940x ?= "3ebf4d172cf4a41d2abf09e4036f0850e08064e7"
+SRCREV_meta_pn-linux-yocto-rt_sys940x ?= "6b3d4e09aa2531e9649f3f03827b7efbccfcec03"
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.2.bbappend
new file mode 100644
index 00000000..52dd3c5c
--- /dev/null
+++ b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.2.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+
+COMPATIBLE_MACHINE_sys940x = "sys940x"
+KMACHINE_sys940x = "sys940x"
+#KBRANCH_sys940x = "standard/default/base"
+SRCREV_machine_pn-linux-yocto_sys940x ?= "f4f8ba730e7783e09413872414d0a17c142c816d"
+SRCREV_meta_pn-linux-yocto_sys940x ?= "6b3d4e09aa2531e9649f3f03827b7efbccfcec03"
+
+COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
+KMACHINE_sys940x-noemgd = "sys940x"
+#KBRANCH_sys940x-noemgd = "standard/default/base"
+SRCREV_machine_pn-linux-yocto_sys940x-noemgd ?= "f4f8ba730e7783e09413872414d0a17c142c816d"
+SRCREV_meta_pn-linux-yocto_sys940x-noemgd ?= "6b3d4e09aa2531e9649f3f03827b7efbccfcec03"