aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/grub-conf
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/grub-conf')
-rw-r--r--recipes-bsp/grub-conf/files/grub.conf21
-rw-r--r--recipes-bsp/grub-conf/grub-conf_1.0.bb16
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/grub-conf/files/grub.conf b/recipes-bsp/grub-conf/files/grub.conf
new file mode 100644
index 0000000..439d258
--- /dev/null
+++ b/recipes-bsp/grub-conf/files/grub.conf
@@ -0,0 +1,21 @@
+default 3
+timeout 3
+
+color white/blue white/cyan
+
+title Clanton SVP kernel-SPI initrd-SPI IMR-On IO-APIC/HPET NoEMU
+ kernel --spi root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,0x8010f000,115200n8 reboot=efi,warm apic=debug rw
+ initrd --spi
+
+title Clanton SVP kernel-SPI image-full on SD IMR-On IO-APIC/HPET NoEMU
+ kernel --spi root=/dev/mmcblk0p2 console=ttyS1,115200n8 earlycon=uart8250,mmio32,0x8010f000,115200n8 reboot=efi,warm apic=debug rw
+
+title Clanton SVP kernel-MassStorage initrd-MassStorage image-full IMR-On IO-APIC/HPET NoEMU debug
+ root (hd0,0)
+ kernel /bzImage root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,0x8010f000,115200n8 reboot=efi,warm apic=debug rw LABEL=boot debugshell=5
+ initrd /core-image-minimal-initramfs-clanton.cpio.gz
+
+title Clanton SVP kernel-MassStorage image-full on SD IMR-On IO-APIC/HPET NoEMU debug
+ root (hd0,0)
+ kernel /bzImage root=/dev/mmcblk0p2 console=ttyS1,115200n8 earlycon=uart8250,mmio32,0x8010f000,115200n8 reboot=efi,warm apic=debug rw LABEL=boot debugshell=5
+
diff --git a/recipes-bsp/grub-conf/grub-conf_1.0.bb b/recipes-bsp/grub-conf/grub-conf_1.0.bb
new file mode 100644
index 0000000..47df56e
--- /dev/null
+++ b/recipes-bsp/grub-conf/grub-conf_1.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "grub.conf"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+GRUB_CONF = "grub.conf"
+GRUB_PATH = "boot/grub/"
+SRC_URI = "file://${GRUB_CONF}"
+
+do_grub() {
+ install -d ${DEPLOY_DIR_IMAGE}/${GRUB_PATH}
+ install -m 0755 ${WORKDIR}/${GRUB_CONF} ${DEPLOY_DIR_IMAGE}/${GRUB_PATH}/${GRUB_CONF}
+}
+
+do_grub[nostamp] = "1"
+
+addtask grub before do_build after do_compile