aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-linux_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-module_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-tests_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc (renamed from recipes-kernel/cryptodev/cryptodev_1.7.inc)11
4 files changed, 25 insertions, 4 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
index 92ccd71..58db505 100644
--- a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
@@ -1,7 +1,9 @@
-require cryptodev_${PV}.inc
+require cryptodev-qoriq_${PV}.inc
SUMMARY = "A /dev/crypto device driver header file"
+PROVIDES = "cryptodev-linux"
+
do_compile[noexec] = "1"
# Just install cryptodev.h which is the only header file needed to be exported
@@ -10,3 +12,5 @@ do_install() {
}
ALLOW_EMPTY_${PN} = "1"
+
+COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
index e6b1f27..383b482 100644
--- a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
@@ -1,10 +1,14 @@
-require cryptodev_${PV}.inc
+require cryptodev-qoriq_${PV}.inc
SUMMARY = "A /dev/crypto device driver kernel module"
+PROVIDES = "cryptodev-module"
+
inherit module qoriq_build_64bit_kernel
# Header file provided by a separate package
DEPENDS += "cryptodev-linux"
EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
+
+COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
index 128ccc9..a60ea98 100644
--- a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
@@ -1,8 +1,10 @@
-require cryptodev_${PV}.inc
+require cryptodev-qoriq_${PV}.inc
SUMMARY = "A test suite for /dev/crypto device driver"
DEPENDS = "openssl"
+PROVIDES = "cryptodev-tests"
+
EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
do_compile() {
@@ -15,3 +17,5 @@ do_install() {
FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
FILES_${PN} = "${bindir}/tests_cryptodev/*"
+
+COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev_1.7.inc b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc
index 2060ce3..e4700db 100644
--- a/recipes-kernel/cryptodev/cryptodev_1.7.inc
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc
@@ -6,6 +6,15 @@ RREPLACES_${PN} = "ocf-linux"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+python() {
+ pkgs = d.getVar('PACKAGES', True).split()
+ for p in pkgs:
+ if 'cryptodev-qoriq' in p:
+ d.appendVar("RPROVIDES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
+ d.appendVar("RCONFLICTS_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
+ d.appendVar("RREPLACES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
+}
+
SRC_URI = "http://download.gna.org/cryptodev-linux/cryptodev-linux-${PV}.tar.gz"
SRC_URI[md5sum] = "0b63b3481cf2c90386b35f057481d36b"
SRC_URI[sha256sum] = "41880533b53de4d7b3f054e230f576988dafb8eed7bef5ebcf6422bb2e3a3b25"
@@ -46,7 +55,7 @@ file://0024-fix-COMPAT_CIOCKEY-ioctl-command-number.patch \
# NOTE: remove this patch and all traces of DISTRO_FEATURE c29x_pkc
# if pkc-host does not need customized cryptodev patches anymore
-SRC_URI_append = "${@bb.utils.contains('DISTRO_FEATURES', 'c29x_pkc', ' file://0001-don-t-advertise-RSA-keygen.patch', '' ,d)}"
+SRC_URI_append = "${@bb.utils.contains('DISTRO_FEATURES', 'c29x_pkc', ' file://0001-don-t-advertise-RSA-keygen.patch', '', d)}"
S = "${WORKDIR}/cryptodev-linux-${PV}"