aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx_5.4.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_5.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_5.4.bb b/recipes-kernel/linux/linux-imx_5.4.bb
new file mode 100644
index 00000000..8c56b986
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx_5.4.bb
@@ -0,0 +1,33 @@
+# Copyright 2013-2016 (C) Freescale Semiconductor
+# Copyright 2017-2020 (C) NXP
+# Copyright 2018 (C) O.S. Systems Software LTDA.
+# Released under the MIT license (see COPYING.MIT for the terms)
+#
+# SPDX-License-Identifier: MIT
+#
+
+SUMMARY = "Linux Kernel provided and supported by NXP"
+DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
+i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
+
+require recipes-kernel/linux/linux-imx.inc
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+DEPENDS += "lzop-native bc-native"
+
+SRCBRANCH = "imx_5.4.24_2.1.0"
+LOCALVERSION = "-2.1.0"
+SRCREV = "babac008e5cf168abca1a85bda2e8071ca27a5c0"
+
+# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
+# required by kernel-yocto.bbclass.
+#
+# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
+# should be updated once patchlevel is merged.
+LINUX_VERSION = "5.4.24"
+
+DEFAULT_PREFERENCE = "1"
+
+COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"