aboutsummaryrefslogtreecommitdiffstats
path: root/openembedded-layer
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded-layer')
-rw-r--r--openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend3
-rw-r--r--openembedded-layer/recipes-kernel/asf/asf_git.bb33
-rw-r--r--openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch46
-rw-r--r--openembedded-layer/recipes-support/opencv/opencv_%.bbappend3
4 files changed, 85 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend b/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
new file mode 100644
index 00000000..8e57d663
--- /dev/null
+++ b/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
@@ -0,0 +1,3 @@
+#Remove gles2 as it is not supported by sololite
+
+PACKAGECONFIG_remove_mx6sl = "gles2"
diff --git a/openembedded-layer/recipes-kernel/asf/asf_git.bb b/openembedded-layer/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 00000000..7cf8f57a
--- /dev/null
+++ b/openembedded-layer/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
+SECTION = "asf"
+LICENSE = "GPLv2 & GPLv2+ & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master"
+SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b"
+
+inherit module
+
+S = "${WORKDIR}/git/asfmodule"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+do_configure_prepend () {
+ find ${S} -name Makefile -exec \
+ sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
+}
+
+do_install(){
+ mkdir -p ${D}/${libexecdir}
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf
+ cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
+ cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
+ cp -rf ${S}/../scripts ${D}/${libexecdir}/
+}
+
+FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
+RDEPENDS_${PN} += "ipsec-tools"
diff --git a/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch b/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
new file mode 100644
index 00000000..274fbe74
--- /dev/null
+++ b/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
@@ -0,0 +1,46 @@
+From 90f869763026e8ff18aeecde217d778f00e4f294 Mon Sep 17 00:00:00 2001
+From: Shawn Xiao <b49994@freescale.com>
+Date: Tue, 10 Feb 2015 16:11:59 +0800
+Subject: [PATCH] MGS-515 [#ccc] Opencv app can't run on imx6sx with cam
+
+This issue is caused by the no support of VIDIOC_QUERYCTRL ioctl
+item in latest cam driver.
+
+Modified the errno in check logic to compatible with new driver.
+
+Feb 10, 2015
+
+Upstream-Status: Pending
+
+Signed-off-by: Shawn Xiao <b49994@freescale.com>
+---
+ modules/highgui/src/cap_v4l.cpp | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/modules/highgui/src/cap_v4l.cpp b/modules/highgui/src/cap_v4l.cpp
+index c9fca05..8c46b6c 100644
+--- a/modules/highgui/src/cap_v4l.cpp
++++ b/modules/highgui/src/cap_v4l.cpp
+@@ -707,7 +707,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
+
+ } else {
+
+- if (errno == EINVAL)
++ if (errno == ENOTTY ||
++ errno == EINVAL)
+ continue;
+
+ perror ("VIDIOC_QUERYCTRL");
+@@ -774,7 +775,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
+
+ } else {
+
+- if (errno == EINVAL)
++ if (errno == ENOTTY ||
++ errno == EINVAL)
+ break;
+
+ perror ("VIDIOC_QUERYCTRL");
+--
+2.3.0
+
diff --git a/openembedded-layer/recipes-support/opencv/opencv_%.bbappend b/openembedded-layer/recipes-support/opencv/opencv_%.bbappend
new file mode 100644
index 00000000..be166965
--- /dev/null
+++ b/openembedded-layer/recipes-support/opencv/opencv_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_mx6sx = " file://0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch"