aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch51
-rw-r--r--meta-openstack/recipes-devtools/python/python-novnc_git.bb18
-rw-r--r--meta-openstack/recipes-extended/novnc/novnc_git.bb52
3 files changed, 121 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch b/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch
new file mode 100644
index 00000000..e8acdede
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch
@@ -0,0 +1,51 @@
+Index: git/setup.py
+===================================================================
+--- /dev/null
++++ git/setup.py
+@@ -0,0 +1,14 @@
++#!/usr/bin/env python
++
++from distutils.core import setup
++
++setup(name='python-novnc',
++ version='2012.1~e3',
++ description='NoVNC python libraries',
++ author='Ghe Rivero',
++ author_email='ghe.rivero@stackops.com',
++ url='http://www.stackops.com',
++ packages = ['novnc'],
++ package_dir = {'novnc':'utils'},
++ py_modules=['wsproxy','websocket','web','json2graph','img2js'],
++)
+Index: git/utils/__init__.py
+===================================================================
+--- /dev/null
++++ git/utils/__init__.py
+@@ -0,0 +1 @@
++# vim: tabstop=4 shiftwidth=4 softtabstop=4
+Index: git/utils/nova-novncproxy
+===================================================================
+--- git.orig/utils/nova-novncproxy
++++ git/utils/nova-novncproxy
+@@ -27,7 +27,7 @@ from oslo.config import cfg
+ import socket
+ import sys
+
+-import websockify
++from novnc import wsproxy
+
+ from nova import config
+ from nova import context
+Index: git/utils/websockify
+===================================================================
+--- git.orig/utils/websockify
++++ git/utils/websockify
+@@ -13,7 +13,7 @@ as taken from http://docs.python.org/dev
+
+ import signal, socket, optparse, time, os, sys, subprocess
+ from select import select
+-import websocket
++from novnc import websocket
+ try:
+ from urllib.parse import parse_qs, urlparse
+ except:
diff --git a/meta-openstack/recipes-devtools/python/python-novnc_git.bb b/meta-openstack/recipes-devtools/python/python-novnc_git.bb
new file mode 100644
index 00000000..6aa54b18
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-novnc_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "This package contains the core python parts of NoVNC"
+HOMEPAGE = "https://github.com/kanaka/noVNC"
+SECTION = "devel/python"
+
+PR = "r0"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ac06308a999996ffc2d24d81b3a39f1b"
+
+SRCREV = "8f12ca7a5a64144fe548cada332d5d19ef26a1fe"
+PV = "0.4+git${SRCPV}"
+
+SRC_URI = "git://github.com/kanaka/noVNC.git \
+ file://python-distutils.patch"
+
+S = "${WORKDIR}/git"
+
+inherit distutils
diff --git a/meta-openstack/recipes-extended/novnc/novnc_git.bb b/meta-openstack/recipes-extended/novnc/novnc_git.bb
new file mode 100644
index 00000000..ee20e3b9
--- /dev/null
+++ b/meta-openstack/recipes-extended/novnc/novnc_git.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "HTML5 VNC client"
+HOMEPAGE = "https://github.com/kanaka/noVNC"
+SECTION = "web"
+
+PR = "r0"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ac06308a999996ffc2d24d81b3a39f1b"
+
+SRCREV = "8f12ca7a5a64144fe548cada332d5d19ef26a1fe"
+PV = "0.4+git${SRCPV}"
+
+SRC_URI = "git://github.com/kanaka/noVNC.git"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} += "python-numpy"
+RDEPENDS_${PN} += "python-novnc"
+RDEPENDS_${PN} += "python-websockify"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ install -m 755 -d ${D}${bindir}/novnc
+ install -m 755 -d ${D}${datadir}/novnc/include
+
+ install -m 644 ${S}/vnc.html ${D}${datadir}/novnc
+ install -m 644 ${S}/vnc_auto.html ${D}${datadir}/novnc
+ install -m 644 ${S}/images/favicon.ico ${D}${datadir}/novnc
+ install -m 644 ${S}/include/base64.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/des.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/display.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/input.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/logo.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/base.css ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/blue.css ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/black.css ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/playback.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/rfb.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/ui.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/util.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/websock.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/webutil.js ${D}${datadir}/novnc/include
+ install -m 644 ${S}/include/jsunzip.js ${D}${datadir}/novnc/include
+
+ sed -i -e 's:#!/usr/bin/env bash:#!/bin/sh:' ${S}/utils/launch.sh
+
+ install -m 755 ${S}/utils/launch.sh ${D}${bindir}/novnc-launch.sh
+}
+