aboutsummaryrefslogtreecommitdiffstats
path: root/meta-r1000
diff options
context:
space:
mode:
Diffstat (limited to 'meta-r1000')
-rw-r--r--meta-r1000/conf/machine/r1000.conf1
-rw-r--r--meta-r1000/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch35
-rw-r--r--meta-r1000/recipes-core/llvm/llvm_git.bbappend15
-rw-r--r--meta-r1000/recipes-graphics/drm/libdrm_git.bbappend3
-rw-r--r--meta-r1000/recipes-graphics/mesa/files/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch33
-rw-r--r--meta-r1000/recipes-graphics/mesa/mesa_git.bbappend18
-rw-r--r--meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend6
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc0
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend3
-rw-r--r--meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend1
10 files changed, 2 insertions, 113 deletions
diff --git a/meta-r1000/conf/machine/r1000.conf b/meta-r1000/conf/machine/r1000.conf
index c656d290..70f9c113 100644
--- a/meta-r1000/conf/machine/r1000.conf
+++ b/meta-r1000/conf/machine/r1000.conf
@@ -9,7 +9,6 @@ PATCH_VERSION = "0"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "4.14%"
-PREFERRED_PROVIDER_llvm ?= "llvm7"
require conf/machine/include/tune-r1000.inc
diff --git a/meta-r1000/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch b/meta-r1000/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
deleted file mode 100644
index 7b490a81..00000000
--- a/meta-r1000/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From ac39269933a9011567722e69c02734beaa1191b3 Mon Sep 17 00:00:00 2001
-From: Martin Kelly <mkelly@xevo.com>
-Date: Fri, 19 May 2017 00:22:57 -0700
-Subject: [PATCH] llvm: allow env override of exe path
-
-When using a native llvm-config from inside a sysroot, we need llvm-config to
-return the libraries, include directories, etc. from inside the sysroot rather
-than from the native sysroot. Thus provide an env override for calling
-llvm-config from a target sysroot.
-
-Signed-off-by: Martin Kelly <mkelly@xevo.com>
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
----
- tools/llvm-config/llvm-config.cpp | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/tools/llvm-config/llvm-config.cpp b/tools/llvm-config/llvm-config.cpp
-index 892adc3b9dd..73b6989fa9e 100644
---- a/tools/llvm-config/llvm-config.cpp
-+++ b/tools/llvm-config/llvm-config.cpp
-@@ -226,6 +226,13 @@ Typical components:\n\
-
- /// Compute the path to the main executable.
- std::string GetExecutablePath(const char *Argv0) {
-+ // Hack for Yocto: we need to override the root path when we are using
-+ // llvm-config from within a target sysroot.
-+ const char *Sysroot = std::getenv("YOCTO_ALTERNATE_EXE_PATH");
-+ if (Sysroot != nullptr) {
-+ return Sysroot;
-+ }
-+
- // This just needs to be some symbol in the binary; C++ doesn't
- // allow taking the address of ::main however.
- void *P = (void *)(intptr_t)GetExecutablePath;
diff --git a/meta-r1000/recipes-core/llvm/llvm_git.bbappend b/meta-r1000/recipes-core/llvm/llvm_git.bbappend
deleted file mode 100644
index 1f2c4ffe..00000000
--- a/meta-r1000/recipes-core/llvm/llvm_git.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=c520ed40e11887bb1d24d86f7f5b1f05"
-
-SRCREV = "4a059213dd6f034147e9083c21133dc1b57b3a8a"
-PV = "7"
-BRANCH = "release_70"
-PATCH_VERSION = "0"
-
-SRC_URI_remove = "file://0001-Disable-generating-a-native-llvm-config.patch"
-
-INSANE_SKIP_${MLPREFIX}libllvm${LLVM_RELEASE}-llvm-${LLVM_RELEASE}.${PATCH_VERSION}.0 += "dev-so"
-
-PACKAGES =+ "${PN}-testplugin"
-FILES_${PN}-testplugin = "${libdir}/${LLVM_DIR}/TestPlugin.so"
-FILES_${PN}-dbg += "${libdir}/${LLVM_DIR}/.debug/TestPlugin.so"
diff --git a/meta-r1000/recipes-graphics/drm/libdrm_git.bbappend b/meta-r1000/recipes-graphics/drm/libdrm_git.bbappend
deleted file mode 100644
index d14d9e46..00000000
--- a/meta-r1000/recipes-graphics/drm/libdrm_git.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-SRCREV_r1000 = "5a3bdc7add2f30f7673052376514c91dbcd1b64a"
-DRM_VERSION_r1000 = "2.4.96"
-SRC_URI_remove_r1000 = "file://0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch"
diff --git a/meta-r1000/recipes-graphics/mesa/files/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch b/meta-r1000/recipes-graphics/mesa/files/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
deleted file mode 100644
index d40aaa98..00000000
--- a/meta-r1000/recipes-graphics/mesa/files/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From ad0ef93a61be1ccd00e3b48bf6913bc2bffb3143 Mon Sep 17 00:00:00 2001
-From: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Date: Fri, 7 Dec 2018 10:08:38 +0100
-Subject: [PATCH] gallium: add missing PIPE_CAP_SURFACE_SAMPLE_COUNT default
- value
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes: 2710c40e3c8 ("gallium: Add new PIPE_CAP_SURFACE_SAMPLE_COUNT")
-Signed-off-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Tested-by: Michel Dänzer <michel.daenzer@amd.com>
----
- src/gallium/auxiliary/util/u_screen.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/gallium/auxiliary/util/u_screen.c b/src/gallium/auxiliary/util/u_screen.c
-index 95d2a7d5701..6ca3992ecd1 100644
---- a/src/gallium/auxiliary/util/u_screen.c
-+++ b/src/gallium/auxiliary/util/u_screen.c
-@@ -328,6 +328,9 @@ u_pipe_screen_get_param_defaults(struct pipe_screen *pscreen,
- case PIPE_CAP_MAX_VERTEX_ELEMENT_SRC_OFFSET:
- return 2047;
-
-+ case PIPE_CAP_SURFACE_SAMPLE_COUNT:
-+ return 0;
-+
- default:
- unreachable("bad PIPE_CAP_*");
- }
---
-2.11.1
-
diff --git a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
index e21af4fa..5211be22 100644
--- a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
+++ b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
@@ -1,17 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRCREV_r1000 = "0144bbdb98f515cce31688fce57d769e7fd82d52"
-LIC_FILES_CHKSUM_r1000 = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
-PV_r1000 = "19.0.0+git${SRCPV}"
-
-MESA_LLVM_RELEASE_r1000 = "7"
-
-SRC_URI_remove_r1000 = "git://anongit.freedesktop.org/mesa/mesa;branch=18.1"
-SRC_URI_append_r1000 = " git://anongit.freedesktop.org/mesa/mesa;branch=master \
- file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
-
-PACKAGECONFIG_append_r1000 = " dri3"
-
-EXTRA_OECONF_remove_r1000 = "--enable-texture-float"
-
-PACKAGES += "${PN}-driconfigs"
-FILES_${PN}-driconfigs += "${datadir}/drirc.d/*"
+PACKAGECONFIG_append_r1000 = " dri3" \ No newline at end of file
diff --git a/meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend b/meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
deleted file mode 100644
index db11aade..00000000
--- a/meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Force X to be run on vt7
-do_install_append_r1000() {
- if [ -f ${D}${sysconfdir}/default/xserver-nodm ]; then
- echo "INPUT_EXTRA_ARGS=vt7" >> ${D}${sysconfdir}/default/xserver-nodm
- fi
-}
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc b/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc
deleted file mode 100644
index e69de29b..00000000
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc
+++ /dev/null
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend b/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
index 8cebf430..d71129e0 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
+++ b/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
@@ -1,4 +1,3 @@
require linux-yocto-r1000_4.14.inc
-SRC_URI_append_r1000 += "file://r1000-standard-only.cfg \
- file://r1000-amdgpu-patches.scc"
+SRC_URI_append_r1000 += "file://r1000-standard-only.cfg"
diff --git a/meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend b/meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
deleted file mode 100644
index 6e603ee9..00000000
--- a/meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-PACKAGECONFIG_append_r1000 = " vaapi"