aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-rocm/hsa/hsa.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-rocm/hsa/hsa.bb')
-rw-r--r--meta-amd-bsp/recipes-rocm/hsa/hsa.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-rocm/hsa/hsa.bb b/meta-amd-bsp/recipes-rocm/hsa/hsa.bb
new file mode 100644
index 00000000..d80faa9c
--- /dev/null
+++ b/meta-amd-bsp/recipes-rocm/hsa/hsa.bb
@@ -0,0 +1,31 @@
+SUMMARY = "AMD Heterogeneous System Architecture HSA"
+DESCRIPTION = "This package includes the user-mode API \
+ interfaces and libraries necessary for host \
+ applications to launch compute kernels to \
+ available HSA kernel agent."
+
+LICENSE = "NCSA"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=abc754edcbe650f4f548eb4efc3cf8d5"
+
+RDEPENDS_${PN} = "libhsakmt"
+
+SRC_URI = "file://hsa.tar.gz"
+SRC_URI[md5sum] = "e27a7b3821a6be61c510542840e865d2"
+
+S = "${WORKDIR}/hsa"
+
+# Skip configure and compile
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+INSANE_SKIP_${PN} += "already-stripped build-deps ldflags"
+
+do_install () {
+ # Install the binary components
+ install -d ${D}${bindir}
+ cp -r ${S}/bin/* ${D}${bindir}
+ install -d ${D}${libdir}
+ cp -r ${S}/lib/* ${D}${libdir}
+ install -d ${D}${includedir}
+ cp -r ${S}/include/* ${D}${includedir}
+}