aboutsummaryrefslogtreecommitdiffstats
path: root/matchbox-panel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'matchbox-panel/Makefile.am')
-rw-r--r--matchbox-panel/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/matchbox-panel/Makefile.am b/matchbox-panel/Makefile.am
new file mode 100644
index 0000000..f28d1af
--- /dev/null
+++ b/matchbox-panel/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS=-DPKGDATADIR=\"$(pkgdatadir)\" \
+ -DGETTEXT_PACKAGE=\"matchbox-panel\" \
+ -DDEFAULT_APPLET_PATH=\"$(libdir)/matchbox-panel\"
+AM_CFLAGS = -Wall -g $(MATCHBOX_PANEL_CFLAGS) \
+ -I$(top_srcdir) -I$(top_builddir) -Werror
+
+matchbox_panelincdir = $(includedir)/matchbox-panel
+
+matchbox_panelinc_HEADERS = mb-panel.h
+
+bin_PROGRAMS = matchbox-panel
+
+matchbox_panel_SOURCES = mb-panel.c mb-panel.h
+
+matchbox_panel_LDADD = $(MATCHBOX_PANEL_LIBS)
+
+CLEANFILES = $(BUILT_SOURCES)
+DISTCLEANFILES = $(BUILT_SOURCES)
+MAINTAINERCLEANFILES = Makefile.in $(BUILT_SOURCES)