aboutsummaryrefslogtreecommitdiffstats
path: root/applets/launcher/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/launcher/Makefile.am')
-rw-r--r--applets/launcher/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/applets/launcher/Makefile.am b/applets/launcher/Makefile.am
new file mode 100644
index 0000000..f874f05
--- /dev/null
+++ b/applets/launcher/Makefile.am
@@ -0,0 +1,11 @@
+AM_CPPFLAGS=-DPKGDATADIR=\"$(pkgdatadir)\" -DGETTEXT_PACKAGE=\"matchbox-panel\"
+AM_CFLAGS = -Wall -g $(MATCHBOX_PANEL_CFLAGS) $(SN_CFLAGS) \
+ -I$(top_srcdir) -I$(top_builddir) -Werror
+
+appletdir = $(libdir)/matchbox-panel
+applet_LTLIBRARIES = liblauncher.la
+
+liblauncher_la_SOURCES = launcher.c
+liblauncher_la_LIBADD = $(SN_LIBS)
+
+MAINTAINERCLEANFILES = Makefile.in