aboutsummaryrefslogtreecommitdiffstats
path: root/applets/exit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/exit/Makefile.am')
-rw-r--r--applets/exit/Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/applets/exit/Makefile.am b/applets/exit/Makefile.am
index 3869891..81260d5 100644
--- a/applets/exit/Makefile.am
+++ b/applets/exit/Makefile.am
@@ -1,17 +1,7 @@
-AM_CPPFLAGS = -DPKGDATADIR=\"$(pkgdatadir)\" \
- -DGETTEXT_PACKAGE=\"matchbox-panel\" \
- $(MATCHBOX_PANEL_CFLAGS) \
- -I$(top_srcdir) -I$(top_builddir)
-AM_CFLAGS = $(WARN_CFLAGS)
+include ../Makefile.applets
-appletdir = $(pkglibdir)
applet_LTLIBRARIES = libexit.la
-
libexit_la_SOURCES = exit.c
-libexit_la_LDFLAGS = -avoid-version
-
-MAINTAINERCLEANFILES = Makefile.in
-
-include ../Makefile.applets
+libexit_la_LDFLAGS = -avoid-version -module
test_linkage_LDADD += libexit.la