aboutsummaryrefslogtreecommitdiffstats
path: root/matchbox2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'matchbox2/Makefile.am')
-rw-r--r--matchbox2/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/matchbox2/Makefile.am b/matchbox2/Makefile.am
new file mode 100644
index 0000000..0ccbac3
--- /dev/null
+++ b/matchbox2/Makefile.am
@@ -0,0 +1,36 @@
+if ENABLE_COMPOSITE
+comp=comp-mgr
+complib= \
+ client-types/libmb-wm-client-override.la \
+ $(comp)/libmatchbox-window-manager-2-compmgr.la
+endif
+
+MAINTAINERCLEANFILES = Makefile.in
+
+pkgincludedir = $(includedir)/$(MBWM2_INCDIR)
+
+SUBDIRS = core client-types theme-engines $(comp)
+
+if ENABLE_LIBMATCHBOX
+lib_LTLIBRARIES = libmatchbox2-@MBWM2_API_VERSION@.la
+
+
+libmatchbox2_@MBWM2_API_VERSION@_la_LIBADD = \
+ core/libmatchbox-window-manager-2-core.la \
+ client-types/libmb-wm-client-app.la \
+ client-types/libmb-wm-client-desktop.la \
+ client-types/libmb-wm-client-dialog.la \
+ client-types/libmb-wm-client-input.la \
+ client-types/libmb-wm-client-menu.la \
+ client-types/libmb-wm-client-note.la \
+ client-types/libmb-wm-client-panel.la \
+ theme-engines/libmb-theme.la \
+ $(complib)
+
+libmatchbox2_@MBWM2_API_VERSION@_la_SOURCES =
+
+pkginclude_HEADERS = *.h
+
+else
+endif
+