aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a31842a..be7f23e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,7 +80,11 @@ if test x"$enable_gtkhtml2" = "xyes"; then
[GTKHTML2_LIBS="$GTKHTML2_LIBS -ljs"
AC_DEFINE(LIBJS_IS_SMJS, 1,
[Define if you have <js/jsapi.h> rather than <smjs/jsapi.h>])],
- [AC_MSG_ERROR([libsmjs not found])],
+ [PKG_CHECK_MODULES(JS, xulrunner-js,
+ [GTKHTML2_LIBS="$GTKHTML2_LIBS $JS_LIBS"
+ AC_DEFINE(LIBJS_IS_MOZJS, 1,
+ [Define if you have <mozjs/jsapi.h>])],
+ [AC_MSG_ERROR([libsmjs not found])])],
[#define XP_UNIX])],
[#define XP_UNIX])