summaryrefslogtreecommitdiffstats
path: root/trunk/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/src/Makefile.am')
-rw-r--r--trunk/src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/trunk/src/Makefile.am b/trunk/src/Makefile.am
index 34760e9..5afb671 100644
--- a/trunk/src/Makefile.am
+++ b/trunk/src/Makefile.am
@@ -2,13 +2,19 @@
AUTOMAKE_OPTIONS = 1.4 gnu
+PKGVERSION = "\"@PKGVERSION@\""
+REPORT_BUGS_TO = "\"@REPORT_BUGS_TO@\""
+
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -Wall
AM_CFLAGS = -Wall
AM_CPPFLAGS = -DSBINDIR='"@sbindir@"' -DBINDIR='"@bindir@"' \
+ -DEXECSTACK_PROG="\"`echo execstack | sed '$(transform)'`\"" \
-DPRELINK_PROG="\"`echo prelink | sed '$(transform)'`\"" \
-DPRELINK_RTLD_PROG="\"`echo prelink-rtld | \
sed '$(transform)'`\"" \
- -DEXEEXT='"$(EXEEXT)"'
+ -DEXEEXT='"$(EXEEXT)"' \
+ -DPKGVERSION=$(PKGVERSION) \
+ -DREPORT_BUGS_TO=$(REPORT_BUGS_TO)
INCLUDES = @GELFINCLUDE@
sbin_PROGRAMS = prelink prelink-rtld