summaryrefslogtreecommitdiffstats
path: root/trunk/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/configure.in')
-rw-r--r--trunk/configure.in44
1 files changed, 42 insertions, 2 deletions
diff --git a/trunk/configure.in b/trunk/configure.in
index 396f3ac..5998659 100644
--- a/trunk/configure.in
+++ b/trunk/configure.in
@@ -1,8 +1,9 @@
dnl Process this file with autoconf to produce a configure script. -*-m4-*-
AC_INIT(src/prelink.c)
AM_CONFIG_HEADER(config.h)
-AC_PREREQ(2.13) dnl Minimum Autoconf version required.
-AC_CANONICAL_HOST
+AC_PREREQ(2.50) dnl Minimum Autoconf version required.
+AC_CANONICAL_SYSTEM
+AC_ARG_PROGRAM
AM_INIT_AUTOMAKE([prelink], [0.0])
@@ -69,6 +70,16 @@ if test "x$ac_cv_ftw_actionretval" = xyes; then
fi
dnl SELinux checks
+AC_ARG_ENABLE(selinux,
+ AS_HELP_STRING([--disable-selinux],
+ [Disable selinux support in the prelinker]),
+ [ enable_selinux="$enableval" ],
+ [ enable_selinux="yes" ])
+
+if test "x$enable_selinux" != "no"; then
+ ac_cv_lib_selinux_is_selinux_enabled=disabled
+fi
+
AC_CHECK_LIB(selinux,is_selinux_enabled)
AC_CHECK_HEADERS(selinux/selinux.h)
@@ -82,6 +93,35 @@ fi
AC_LIBELF_SXWORD
+dnl Elf64_Byte is specific to the 64-bit MIPS psABI and may not be defined.
+AC_CHECK_TYPES([Elf64_Byte], [], [], [#include <libelf.h>])
+
+# Package version.
+AC_ARG_WITH(pkgversion,
+ AS_HELP_STRING([--with-pkgversion=PKG],
+ [Add PKG to the version string]),
+ [case "$withval" in
+ yes) AC_MSG_ERROR([package version not specified]) ;;
+ no) PKGVERSION= ;;
+ *) PKGVERSION=" ($withval)" ;;
+ esac],
+ PKGVERSION=
+)
+AC_SUBST(PKGVERSION)
+
+# The location to which bugs should be reported.
+AC_ARG_WITH(bugurl,
+ AS_HELP_STRING([--with-bugurl=URL],
+ [Direct users to URL to report a bug]),
+ [case "$withval" in
+ yes) AC_MSG_ERROR([bug URL not specified]) ;;
+ no) REPORT_BUGS_TO="" ;;
+ *) REPORT_BUGS_TO="<URL:$withval>" ;;
+ esac],
+ REPORT_BUGS_TO="<jakub@redhat.com>"
+)
+AC_SUBST(REPORT_BUGS_TO)
+
AC_OUTPUT([Makefile
src/Makefile
gelfx/Makefile