summaryrefslogtreecommitdiffstats
path: root/trunk/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/configure.in')
-rw-r--r--trunk/configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/trunk/configure.in b/trunk/configure.in
index 86a2513..724262b 100644
--- a/trunk/configure.in
+++ b/trunk/configure.in
@@ -93,6 +93,32 @@ fi
AC_LIBELF_SXWORD
+# Package version.
+AC_ARG_WITH(pkgversion,
+ AS_HELP_STRING([--with-pkgversion=PKG],
+ [Add PKG to the version string]),
+ [case "$withval" in
+ yes) AC_MSG_ERROR([package version not specified]) ;;
+ no) PKGVERSION= ;;
+ *) PKGVERSION=" ($withval)" ;;
+ esac],
+ PKGVERSION=
+)
+AC_SUBST(PKGVERSION)
+
+# The location to which bugs should be reported.
+AC_ARG_WITH(bugurl,
+ AS_HELP_STRING([--with-bugurl=URL],
+ [Direct users to URL to report a bug]),
+ [case "$withval" in
+ yes) AC_MSG_ERROR([bug URL not specified]) ;;
+ no) REPORT_BUGS_TO="" ;;
+ *) REPORT_BUGS_TO="<URL:$withval>" ;;
+ esac],
+ REPORT_BUGS_TO="<jakub@redhat.com>"
+)
+AC_SUBST(REPORT_BUGS_TO)
+
AC_OUTPUT([Makefile
src/Makefile
gelfx/Makefile