aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb')
-rw-r--r--meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
new file mode 100644
index 0000000000..cc1ec75da1
--- /dev/null
+++ b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
@@ -0,0 +1,58 @@
+SUMMARY = "Universally Unique Identifier (UUID) library"
+DESCRIPTION = "OSSP uuid is a ISO-C:1999 application programming interface \
+(API) and corresponding command line interface (CLI) for the generation of \
+DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique \
+Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1 (time \
+and node based), version 3 (name based, MD5), version 4 (random number \
+based) and version 5 (name based, SHA-1)."
+DESCRIPTION_uuid = "This package contains a tool to create Universally \
+Unique Identifiers (UUID) from the command-line."
+
+HOMEPAGE = "http://www.ossp.org/pkg/lib/uuid/"
+SECTION = "libs"
+
+LICENSE = "ossp_uuid"
+LIC_FILES_CHKSUM = "file://README;beginline=30;endline=55;md5=b394fadb039bbfca6ad9d9d769ee960e"
+
+PR = "r0"
+
+SRC_URI = "ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz \
+ file://0001-Change-library-name.patch \
+ file://0002-uuid-preserve-m-option-status-in-v-option-handling.patch \
+ file://0003-Fix-whatis-entries.patch \
+ file://0004-fix-data-uuid-from-string.patch \
+ file://uuid-libtool.patch \
+ file://uuid-nostrip.patch \
+ "
+SRC_URI[md5sum] = "5db0d43a9022a6ebbbc25337ae28942f"
+SRC_URI[sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0"
+
+S = "${WORKDIR}/uuid-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-dce --without-cxx --without-perl --without-perl-compat --without-php --without-pgsql"
+EXTRA_OECONF = "--includedir=${includedir}/ossp"
+
+do_configure_prepend() {
+ # This package has a completely custom aclocal.m4
+ # so we need to back it up and make it usable...
+ if [ ! -e m4/ossp.m4 ]; then
+ mkdir m4
+ mv aclocal.m4 m4/ossp.m4
+ fi
+
+ rm -f libtool.m4
+}
+
+do_install_append() {
+ mkdir -p ${D}${includedir}/ossp
+ mv ${D}${libdir}/pkgconfig/uuid.pc ${D}${libdir}/pkgconfig/ossp-uuid.pc
+}
+
+PACKAGES =+ "uuid"
+FILES_uuid = "${bindir}/uuid"
+FILES_${PN} = "${libdir}/libossp-uuid.so.16*"
+FILES_${PN}-dev += "${bindir}/uuid-config"
+
+BBCLASSEXTEND = "native"