summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb')
-rw-r--r--meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb b/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
new file mode 100644
index 0000000000..e3ac0017ff
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Parsing and Encoding of WBXML documents"
+DESCRIPTION = "The WBXML Library (aka libwbxml) contains a library and \
+its associated tools to Parse, Encode and Handle WBXML documents. The \
+WBXML format is a binary representation of XML, defined by the Wap \
+Forum, and used to reduce bandwidth in mobile communications."
+LICENSE = "GPLv2"
+
+DEPENDS = "libxml2 sed-native expat"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
+ file://no-doc-install.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ sed -i s:-I/usr/include::g Makefile
+ sed -i s:-I/usr/include::g */Makefile
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+