summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2012-04-01 10:24:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-02 04:31:47 +0100
commit84b7541abc2d7e59c22891219fce97d320d3bb33 (patch)
treea61a25389d59161495a2df9ccc324149e0393c07 /scripts
parent2592a11bde92bb39ca7d2273758e25b73ab5f54d (diff)
downloadpoky-84b7541abc2d7e59c22891219fce97d320d3bb33.tar.gz
poky-84b7541abc2d7e59c22891219fce97d320d3bb33.tar.bz2
poky-84b7541abc2d7e59c22891219fce97d320d3bb33.zip
qemugl: Fix GL apps failure on Ubuntu 11 host with nVidia GLX driver
Previous version of nVidia GLX driver in Ubuntu 10 cause qemu segfault, so we fall back to Mesa GLX driver if detecting nVidia driver installed. From Ubuntu 11, nVidia GLX driver works well, while previous work around cause GL apps failure. So this work around is limited in Ubuntu 10 only, and will be removed in future. [YOCTO #1886] got fixed. (From OE-Core rev: b3ccc630e6c12a75111b1f7ca877e17d8d4e1dc7) Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/runqemu-internal11
1 files changed, 8 insertions, 3 deletions
diff --git a/scripts/runqemu-internal b/scripts/runqemu-internal
index 73b8b41ec4..92f245a112 100755
--- a/scripts/runqemu-internal
+++ b/scripts/runqemu-internal
@@ -467,11 +467,15 @@ cat << EOM
WARNING: nVidia proprietary OpenGL libraries detected.
nVidia's OpenGL libraries are known to have compatibility issues with qemu,
resulting in a segfault. Please uninstall these drivers or ensure the mesa libGL
-libraries precede nvidia's via LD_PRELOAD(Already do it on Ubuntu).
+libraries precede nvidia's via LD_PRELOAD(Already do it on Ubuntu 10).
EOM
# Automatically use Ubuntu system's mesa libGL, other distro can add its own path
- if grep -i ubuntu /etc/lsb-release &> /dev/null
+if grep -i ubuntu /etc/lsb-release &> /dev/null
+then
+ # precede nvidia's driver on Ubuntu 10
+ UBUNTU_MAIN_VERSION=`cat /etc/lsb-release |grep DISTRIB_RELEASE |cut -d= -f 2| cut -d. -f 1`
+ if [ $UBUNTU_MAIN_VERSION -eq 10 ];
then
GL_PATH=""
if test -e /usr/lib/libGL.so
@@ -482,10 +486,11 @@ EOM
GL_PATH="/usr/lib/x86_64-linux-gnu/libGL.so"
fi
- echo "Skip nVidia's libGL on Ubuntu!"
+ echo "Skip nVidia's libGL on Ubuntu 10!"
GL_LD_PRELOAD="$GL_PATH $LD_PRELOAD"
fi
fi
+fi
echo "Running $QEMU..."
# -no-reboot is a mandatory option - see bug #100