summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-12-04 11:59:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-10 22:45:19 +0000
commitd8ebe9ad6e69ca827b88673568a7b42b9f66451d (patch)
treeb8fb96dbe1a4b4c63a5d0a60c61fbefea3c80666
parent0e0a94c200a877cbc29ffeab81e5e857cdd9b485 (diff)
downloadpoky-d8ebe9ad6e69ca827b88673568a7b42b9f66451d.tar.gz
poky-d8ebe9ad6e69ca827b88673568a7b42b9f66451d.tar.bz2
poky-d8ebe9ad6e69ca827b88673568a7b42b9f66451d.zip
libbsd: Make it build with GCC 5.0 and older
(From OE-Core rev: 2a769d0831cf368992cf540e7758cc2c2d9067ab) Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/libbsd/libbsd/0001-Fix-for-older-GCCs-not-supporting-__has_include.patch31
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.8.6.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd/0001-Fix-for-older-GCCs-not-supporting-__has_include.patch b/meta/recipes-support/libbsd/libbsd/0001-Fix-for-older-GCCs-not-supporting-__has_include.patch
new file mode 100644
index 0000000000..d13732bdaf
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd/0001-Fix-for-older-GCCs-not-supporting-__has_include.patch
@@ -0,0 +1,31 @@
+From 2fbf47ce9b64f4e07be223bc2870348a68f19d86 Mon Sep 17 00:00:00 2001
+From: Adam Lackorzynski <adam@l4re.org>
+Date: Sat, 21 Oct 2017 23:08:31 +0200
+Subject: [PATCH] Fix for older GCCs not supporting __has_include*
+
+Upstream-Status: Submitted [https://bugs.freedesktop.org/show_bug.cgi?id=103396]
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ include/bsd/sys/cdefs.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/bsd/sys/cdefs.h b/include/bsd/sys/cdefs.h
+index 044f221..b4c8f30 100644
+--- a/include/bsd/sys/cdefs.h
++++ b/include/bsd/sys/cdefs.h
+@@ -25,10 +25,10 @@
+ */
+
+ #ifndef __has_include
+-#define __has_include 1
++#define __has_include(x) 1
+ #endif
+ #ifndef __has_include_next
+-#define __has_include_next 1
++#define __has_include_next(x) 1
+ #endif
+
+ #ifdef LIBBSD_OVERLAY
+--
+2.12.0
+
diff --git a/meta/recipes-support/libbsd/libbsd_0.8.6.bb b/meta/recipes-support/libbsd/libbsd_0.8.6.bb
index 182543fd42..c88517f5b5 100644
--- a/meta/recipes-support/libbsd/libbsd_0.8.6.bb
+++ b/meta/recipes-support/libbsd/libbsd_0.8.6.bb
@@ -36,6 +36,7 @@ SECTION = "libs"
SRC_URI = " \
http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
file://0001-src-libbsd-overlay.pc.in-Set-Cflags-to-use-I-instead.patch \
+ file://0001-Fix-for-older-GCCs-not-supporting-__has_include.patch \
"
SRC_URI_append_libc-musl = " \
file://0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch \