summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-06-14 16:27:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-15 13:46:38 +0100
commit27d60c5a812774f0e5c43161e5b514c4aebdf301 (patch)
tree421bb09af266486229a7751a389a98c3ec76d776
parent4f60156ec116cf7fa61217fd6abcf6df6d019da9 (diff)
downloadpoky-27d60c5a812774f0e5c43161e5b514c4aebdf301.tar.gz
poky-27d60c5a812774f0e5c43161e5b514c4aebdf301.tar.bz2
poky-27d60c5a812774f0e5c43161e5b514c4aebdf301.zip
gstreamer1.0-libav: disable API documentation
With the latest gtk-doc release the gstreamer1.0-libav documentation fails to build: | gst-libav-plugins-docs.sgml:38: element include: XInclude error: | could not load xml/tree_index.sgml, and no fallback was found For the short term we can just disable the documentation. The next upstream release of gstreamer1.0-libav doesn't use gtk-doc anyway. (From OE-Core rev: 27744ad292c9d7e57ebcf7c3c30acbd85aac77a4) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.0.bb
index 3f1ec99d95..d94c3215dc 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.0.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.0.bb
@@ -28,6 +28,11 @@ DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base zlib bzip2 xz"
inherit autotools pkgconfig upstream-version-is-even gtk-doc
+# Disable documentation for now as it is failing with gtk-doc 1.30:
+# gst-libav-plugins-docs.sgml:38: element include: XInclude error:
+# could not load xml/tree_index.sgml, and no fallback was found
+GTKDOC_ENABLED = "False"
+
# CAUTION: Using the system libav is not recommended. Since the libav API is changing all the time,
# compilation errors (and other, more subtle bugs) can happen. It is usually better to rely on the
# libav copy included in the gst-libav package.