aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/boards/ze7000/ze7000-zynq7.dts14
-rw-r--r--recipes-kernel/linux/linux-xlnx/zx3-zynq7/0001-zx3-phy-micrel-phy-init.patch82
-rw-r--r--recipes-kernel/linux/linux-xlnx/zx3-zynq7/0002-zx3-phy-adapt-marvell-settings.patch51
-rw-r--r--recipes-kernel/linux/linux-xlnx/zx3-zynq7/0003-zx3-xilinx_emacps-make-phy-address-configurable.patch150
-rw-r--r--recipes-kernel/linux/linux-xlnx/zx3-zynq7/0004-zx3-sdhci-add-sd-card-support.patch69
-rw-r--r--recipes-kernel/linux/linux-xlnx/zx3-zynq7/0005-xilinx_emacps-allow-MTU-of-1500.patch27
-rw-r--r--recipes-kernel/linux/linux-xlnx/zx3-zynq7/0006-xilinx_emacps-Set-the-maximum-frame-reception-size-t.patch36
-rw-r--r--recipes-kernel/linux/linux-xlnx/zx3-zynq7/0007-net-phy-disable-buggy-pause-feature-of-micrel-KSZ903.patch31
-rw-r--r--recipes-kernel/linux/linux-xlnx_3.14.bbappend25
9 files changed, 12 insertions, 473 deletions
diff --git a/conf/machine/boards/ze7000/ze7000-zynq7.dts b/conf/machine/boards/ze7000/ze7000-zynq7.dts
index 89c4d45..0f988ac 100644
--- a/conf/machine/boards/ze7000/ze7000-zynq7.dts
+++ b/conf/machine/boards/ze7000/ze7000-zynq7.dts
@@ -37,14 +37,10 @@
ps7_nand_0: ps7-nand@e1000000 {
compatible = "arm,pl353-nand-r2p1";
reg = <0xe1000000 0x1000000>;
- /* timings in smc cycles count */
- arm,nand-cycle-t0 = <3>; /* tRC */
- arm,nand-cycle-t1 = <3>; /* tWC */
- arm,nand-cycle-t2 = <1>; /* tREA */
- arm,nand-cycle-t3 = <2>; /* tWP */
- arm,nand-cycle-t4 = <2>; /* tCLR */
- arm,nand-cycle-t5 = <2>; /* tAR */
- arm,nand-cycle-t6 = <3>; /* tRR */
+
+ /* Timings are set by FSBL, linux should not change them.
+ Look out for DONT_TOUCH_SMC_NAND_TIMING_WIDTH in pl353-smc.c */
+
#address-cells = <0x1>;
#size-cells = <0x1>;
@@ -67,7 +63,7 @@
ps7_ethernet_0: ps7-ethernet@e000b000 {
phy-handle = <&phy0>;
- phy-mode = "rgmii-id";
+ phy-mode = "";
mdio {
phy0: phy@3 {
compatible = "micrel,ksz9031";
diff --git a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0001-zx3-phy-micrel-phy-init.patch b/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0001-zx3-phy-micrel-phy-init.patch
deleted file mode 100644
index bb91b25..0000000
--- a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0001-zx3-phy-micrel-phy-init.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From 6d2d7391ae48ce320e6a3a9efd21d2b40488ac19 Mon Sep 17 00:00:00 2001
-From: David Andrey <david.andrey@netmodule.com>
-Date: Fri, 27 Jun 2014 11:05:22 +0200
-Subject: [PATCH 1/7] zx3: phy: micrel phy init
-
-Use a custom init for Micrel KSZ9031
-Each time the PL is loaded, the PHY goes in reset.
-The PHY settings must be done again.
-
-Signed-off-by: David Andrey <david.andrey@netmodule.com>
-
-Conflicts:
- drivers/net/phy/micrel.c
- include/linux/micrel_phy.h
----
- drivers/net/phy/micrel.c | 41 +++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 41 insertions(+)
-
-diff --git a/drivers/net/phy/micrel.c b/drivers/net/phy/micrel.c
-index 5a8993b..412d144 100644
---- a/drivers/net/phy/micrel.c
-+++ b/drivers/net/phy/micrel.c
-@@ -27,6 +27,8 @@
- #include <linux/micrel_phy.h>
- #include <linux/of.h>
-
-+#define NETMODULE_ZX3 /* some specific board init */
-+
- /* Operation Mode Strap Override */
- #define MII_KSZPHY_OMSO 0x16
- #define KSZPHY_OMSO_B_CAST_OFF (1 << 9)
-@@ -148,9 +150,48 @@ static int ks8737_config_intr(struct phy_device *phydev)
- return rc < 0 ? rc : 0;
- }
-
-+/*
-+ * On the Enclustra ZX3 module, each FPGA reset leads
-+ * to a PHY reset too. So let's do the setup again
-+ * @@ netmodule, da
-+ */
-+static int zx3_config_init(struct phy_device *phydev)
-+{
-+ int err;
-+
-+ if (((phydev->phy_id & ~PHY_ID_KSZ9031) & phydev->drv->phy_id_mask) == 0) {
-+
-+ err = phy_write(phydev, 0xD, 0x0002);
-+ if (err < 0)
-+ return err;
-+
-+ err = phy_write(phydev, 0xE, 0x0008); /* Reg 0x8 */
-+ if (err < 0)
-+ return err;
-+
-+ err = phy_write(phydev, 0xD, 0x4002);
-+ if (err < 0)
-+ return err;
-+
-+ err = phy_write(phydev, 0xE, 0x03FF); /* 3FF = max RXC and TXC delay */
-+ if (err < 0)
-+ return err;
-+ }
-+
-+ else {
-+ printk (KERN_ERR "ZX3 unsupported PHY ID\n");
-+ }
-+
-+ return 0;
-+}
-+
- static int kszphy_config_init(struct phy_device *phydev)
- {
-+#ifdef NETMODULE_ZX3
-+ return zx3_config_init (phydev);
-+#else
- return 0;
-+#endif
- }
-
- static int ksz8021_config_init(struct phy_device *phydev)
---
-1.7.10.4
diff --git a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0002-zx3-phy-adapt-marvell-settings.patch b/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0002-zx3-phy-adapt-marvell-settings.patch
deleted file mode 100644
index 3349f5c..0000000
--- a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0002-zx3-phy-adapt-marvell-settings.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From b266e1a7ff8073d0437fcafc51ba5f97bf523fc5 Mon Sep 17 00:00:00 2001
-From: David Andrey <david.andrey@netmodule.com>
-Date: Fri, 27 Jun 2014 11:39:31 +0200
-Subject: [PATCH 2/7] zx3: phy: adapt marvell settings
-
-The onboard PHY is compatible with the 88E1116R,
-based on the UID at least
-Marvell settings are overwritten to met the board
-requirements
-
-Signed-off-by: David Andrey <david.andrey@netmodule.com>
----
- drivers/net/phy/marvell.c | 19 ++++++++++++++++++-
- 1 file changed, 18 insertions(+), 1 deletion(-)
-
-diff --git a/drivers/net/phy/marvell.c b/drivers/net/phy/marvell.c
-index bd37e45..d36686a 100644
---- a/drivers/net/phy/marvell.c
-+++ b/drivers/net/phy/marvell.c
-@@ -414,11 +414,28 @@ static int m88e1116r_config_init(struct phy_device *phydev)
- if (err < 0)
- return err;
- temp = phy_read(phydev, MII_M1116R_CONTROL_REG_MAC);
-- temp |= (1 << 5);
-+ temp &= ~(1 << 5); /* @@ NetModule, da, set correct mode for ZE7000 board */
- temp |= (1 << 4);
- err = phy_write(phydev, MII_M1116R_CONTROL_REG_MAC, temp);
- if (err < 0)
- return err;
-+
-+ /* @@ NetModule, da, LED settings */
-+ err = phy_write(phydev, MII_MARVELL_PHY_PAGE, 3);
-+ if (err < 0)
-+ return err;
-+
-+ temp = 0x1040;
-+ err = phy_write(phydev, 16, temp);
-+ if (err < 0)
-+ return err;
-+
-+ temp = 0x4405;
-+ err = phy_write(phydev, 17, temp);
-+ if (err < 0)
-+ return err;
-+
-+
- err = phy_write(phydev, MII_MARVELL_PHY_PAGE, 0);
- if (err < 0)
- return err;
---
-1.7.10.4
diff --git a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0003-zx3-xilinx_emacps-make-phy-address-configurable.patch b/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0003-zx3-xilinx_emacps-make-phy-address-configurable.patch
deleted file mode 100644
index e44f269..0000000
--- a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0003-zx3-xilinx_emacps-make-phy-address-configurable.patch
+++ /dev/null
@@ -1,150 +0,0 @@
-From de4fae1849b4d29146a6061f76b763d92cc7e3ef Mon Sep 17 00:00:00 2001
-From: David Andrey <david.andrey@netmodule.com>
-Date: Tue, 1 Jul 2014 09:33:51 +0200
-Subject: [PATCH 3/7] zx3: xilinx_emacps: make phy address configurable
-
-Make the address of the phy configurable so
-we can change it at runtime.
-
-Signed-off-by: Stefan Eichenberger <stefan.eichenberger@netmodule.com>
-
-Conflicts:
- drivers/net/ethernet/xilinx/xilinx_emacps.c
----
- drivers/net/ethernet/xilinx/xilinx_emacps.c | 86 +++++++++++++++++++++++++++
- 1 file changed, 86 insertions(+)
-
-diff --git a/drivers/net/ethernet/xilinx/xilinx_emacps.c b/drivers/net/ethernet/xilinx/xilinx_emacps.c
-index af61503..aba7747 100644
---- a/drivers/net/ethernet/xilinx/xilinx_emacps.c
-+++ b/drivers/net/ethernet/xilinx/xilinx_emacps.c
-@@ -47,6 +47,7 @@
- #include <linux/ptp_clock_kernel.h>
-
- /************************** Constant Definitions *****************************/
-+#define MAKE_PHY_ADDR_CHANGEABLE
-
- /* Must be shorter than length of ethtool_drvinfo.driver field to fit */
- #define DRIVER_NAME "xemacps"
-@@ -545,6 +546,9 @@ struct net_local {
- unsigned ip_summed;
- unsigned int enetnum;
- unsigned int lastrxfrmscntr;
-+#ifdef MAKE_PHY_ADDR_CHANGEABLE
-+ unsigned int phy_number;
-+#endif /* MAKE_PHY_ADDR_CHANGEABLE */
- #ifdef CONFIG_XILINX_PS_EMAC_HWTSTAMP
- struct hwtstamp_config hwtstamp_config;
- struct ptp_clock *ptp_clock;
-@@ -867,6 +871,44 @@ err_out:
- return rc;
- }
-
-+#ifdef MAKE_PHY_ADDR_CHANGEABLE
-+static int xemacps_set_phy(struct net_local *lp, int phy_number)
-+{
-+ struct device_node *phy_node;
-+ int ret;
-+
-+ phy_node = of_parse_phandle(lp->pdev->dev.of_node,
-+ "phy-handle", phy_number);
-+ if (phy_node == NULL){
-+ return -1;
-+ }
-+
-+ if (lp->phy_dev) {
-+ phy_disconnect(lp->phy_dev);
-+ lp->phy_dev = NULL;
-+ }
-+
-+ of_node_put(lp->phy_node);
-+
-+ lp->phy_number = phy_number;
-+
-+ lp->phy_node = phy_node;
-+
-+ ret = xemacps_mii_probe(lp->ndev);
-+ if (ret == -1) {
-+ printk (KERN_ERR "Failed to probe phy!");
-+ return -1;
-+ }
-+
-+ return 0;
-+}
-+
-+static int xemacps_get_phy(struct net_local *lp)
-+{
-+ return lp->phy_number;
-+}
-+#endif /* MAKE_PHY_ADDR_CHANGEABLE */
-+
- /**
- * xemacps_update_hdaddr - Update device's MAC address when configured
- * MAC address is not valid, reconfigure with a good one.
-@@ -2782,6 +2824,41 @@ static int xemacps_ioctl(struct net_device *ndev, struct ifreq *rq, int cmd)
-
- }
-
-+#ifdef MAKE_PHY_ADDR_CHANGEABLE
-+static ssize_t
-+xemacps_sysfs_show_phy_num(struct device *dev, struct device_attribute *attr,
-+ char *buf)
-+{
-+ struct net_device *ndev = to_net_dev(dev);
-+ struct net_local *lp = netdev_priv(ndev);
-+
-+ /* External phy numbers are from 1 to *, internal phy numbers from 0 to * */
-+ return sprintf (buf,"%d\n", xemacps_get_phy(lp) + 1);
-+
-+}
-+
-+static ssize_t
-+xemacps_sysfs_store_phy_num(struct device *dev, struct device_attribute *attr,
-+ char *buf, size_t n)
-+{
-+ struct net_device *ndev = to_net_dev(dev);
-+ struct net_local *lp = netdev_priv(ndev);
-+ unsigned int phy_number = simple_strtoul(buf, NULL, 10);
-+ if (phy_number == 0)
-+ return -EINVAL;
-+
-+ /* External phy numbers are from 1 to *, internal phy numbers from 0 to * */
-+ phy_number --;
-+ if (xemacps_set_phy(lp, phy_number) != 0)
-+ return -EINVAL;
-+
-+ return n;
-+}
-+
-+static DEVICE_ATTR(phy_num, S_IRUGO | S_IWUSR, xemacps_sysfs_show_phy_num, xemacps_sysfs_store_phy_num);
-+
-+#endif /* MAKE_PHY_ADDR_CHANGEABLE */
-+
- /**
- * xemacps_probe - Platform driver probe
- * @pdev: Pointer to platform device structure
-@@ -2909,6 +2986,11 @@ static int xemacps_probe(struct platform_device *pdev)
- lp->txtimeout_handler_wq = create_singlethread_workqueue(DRIVER_NAME);
- INIT_WORK(&lp->txtimeout_reinit, xemacps_reinit_for_txtimeout);
-
-+#ifdef MAKE_PHY_ADDR_CHANGEABLE
-+ lp->phy_number = 0;
-+ device_create_file(&ndev->dev, &dev_attr_phy_num);
-+#endif /* MAKE_PHY_ADDR_CHANGEABLE */
-+
- platform_set_drvdata(pdev, ndev);
- pm_runtime_set_active(&pdev->dev);
- pm_runtime_enable(&pdev->dev);
-@@ -2952,6 +3034,10 @@ static int xemacps_remove(struct platform_device *pdev)
- if (ndev) {
- lp = netdev_priv(ndev);
-
-+#ifdef MAKE_PHY_ADDR_CHANGEABLE
-+ device_remove_file(&ndev->dev, &dev_attr_phy_num);
-+#endif /* MAKE_PHY_ADDR_CHANGEABLE */
-+
- mdiobus_unregister(lp->mii_bus);
- kfree(lp->mii_bus->irq);
- mdiobus_free(lp->mii_bus);
---
-1.7.10.4
diff --git a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0004-zx3-sdhci-add-sd-card-support.patch b/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0004-zx3-sdhci-add-sd-card-support.patch
deleted file mode 100644
index a0c0183..0000000
--- a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0004-zx3-sdhci-add-sd-card-support.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From b4712e0b848ab662a57cbf8dc8ffd5053c3e6ef5 Mon Sep 17 00:00:00 2001
-From: David Andrey <david.andrey@netmodule.com>
-Date: Tue, 1 Jul 2014 09:38:12 +0200
-Subject: [PATCH 4/7] zx3: sdhci: add sd card support
-
-Disable the card detect for the ZX3 module as not
-supported and avoid correct initialization
-
-Signed-off-by: Marcel Reichmuth <marcel.reichmuth@netmodule.com>
----
- drivers/mmc/host/sdhci.c | 32 +++++++++++++++-----------------
- 1 file changed, 15 insertions(+), 17 deletions(-)
-
-diff --git a/drivers/mmc/host/sdhci.c b/drivers/mmc/host/sdhci.c
-index 9ddef47..72e8bfc 100644
---- a/drivers/mmc/host/sdhci.c
-+++ b/drivers/mmc/host/sdhci.c
-@@ -990,9 +990,20 @@ void sdhci_send_command(struct sdhci_host *host, struct mmc_command *cmd)
- int flags;
- u32 mask;
- unsigned long timeout;
-+ u8 ctrl;
-
- WARN_ON(host->cmd);
-
-+ /* Make sure that the card detect logic of the controller is disabled.
-+ This is necessary, because there seems to be a bug in the hardware
-+ which causes the controller to report a card removed event and
-+ automatically disable power and clock of the card during a data
-+ transfer.
-+ */
-+ ctrl = sdhci_readb(host, SDHCI_HOST_CONTROL);
-+ ctrl |= 0xc0;
-+ sdhci_writeb(host, ctrl, SDHCI_HOST_CONTROL);
-+
- /* Wait max 10 ms */
- timeout = 10;
-
-@@ -1648,24 +1659,11 @@ static int sdhci_get_cd(struct mmc_host *mmc)
-
- static int sdhci_check_ro(struct sdhci_host *host)
- {
-- unsigned long flags;
-- int is_readonly;
--
-- spin_lock_irqsave(&host->lock, flags);
--
-- if (host->flags & SDHCI_DEVICE_DEAD)
-- is_readonly = 0;
-- else if (host->ops->get_ro)
-- is_readonly = host->ops->get_ro(host);
-- else
-- is_readonly = !(sdhci_readl(host, SDHCI_PRESENT_STATE)
-- & SDHCI_WRITE_PROTECT);
--
-- spin_unlock_irqrestore(&host->lock, flags);
-+ /*
-+ Write protect is not supported, so allways return false.
-+ */
-
-- /* This quirk needs to be replaced by a callback-function later */
-- return host->quirks & SDHCI_QUIRK_INVERTED_WRITE_PROTECT ?
-- !is_readonly : is_readonly;
-+ return 0;
- }
-
- #define SAMPLE_COUNT 5
---
-1.7.10.4
diff --git a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0005-xilinx_emacps-allow-MTU-of-1500.patch b/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0005-xilinx_emacps-allow-MTU-of-1500.patch
deleted file mode 100644
index beceb6f..0000000
--- a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0005-xilinx_emacps-allow-MTU-of-1500.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From b416616d5767a0547e917f8b5408199e08eda7e4 Mon Sep 17 00:00:00 2001
-From: David Andrey <david.andrey@netmodule.com>
-Date: Tue, 1 Jul 2014 09:44:51 +0200
-Subject: [PATCH 5/7] xilinx_emacps: allow MTU of 1500
-
-It is now possible to set an MTU of 1500.
-
-Signed-off-by: Stefan Eichenberger <stefan.eichenberger@netmodule.com>
----
- drivers/net/ethernet/xilinx/xilinx_emacps.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/drivers/net/ethernet/xilinx/xilinx_emacps.c b/drivers/net/ethernet/xilinx/xilinx_emacps.c
-index aba7747..a08be55 100644
---- a/drivers/net/ethernet/xilinx/xilinx_emacps.c
-+++ b/drivers/net/ethernet/xilinx/xilinx_emacps.c
-@@ -2482,7 +2482,7 @@ static void xemacps_set_rx_mode(struct net_device *ndev)
- static int xemacps_change_mtu(struct net_device *ndev, int new_mtu)
- {
- if ((new_mtu < MIN_MTU) ||
-- ((new_mtu + ndev->hard_header_len) > MAX_MTU))
-+ (new_mtu > MAX_MTU))
- return -EINVAL;
-
- ndev->mtu = new_mtu; /* change mtu in net_device structure */
---
-1.7.10.4
diff --git a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0006-xilinx_emacps-Set-the-maximum-frame-reception-size-t.patch b/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0006-xilinx_emacps-Set-the-maximum-frame-reception-size-t.patch
deleted file mode 100644
index 4e81c53..0000000
--- a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0006-xilinx_emacps-Set-the-maximum-frame-reception-size-t.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 117e4a311d0004aa3d5a285cb4e57e5bdd3bb644 Mon Sep 17 00:00:00 2001
-From: David Andrey <david.andrey@netmodule.com>
-Date: Tue, 1 Jul 2014 10:08:44 +0200
-Subject: [PATCH 6/7] xilinx_emacps: Set the maximum frame reception size to
- 1536
-
-To make it possible for the driver to receive packets > 1518,
-the mode 1536RXEN is now set in the MAC configuration.
-
-Signed-off-by: Stefan Eichenberger <stefan.eichenberger@netmodule.com>
----
- drivers/net/ethernet/xilinx/xilinx_emacps.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/drivers/net/ethernet/xilinx/xilinx_emacps.c b/drivers/net/ethernet/xilinx/xilinx_emacps.c
-index a08be55..0ca989e 100644
---- a/drivers/net/ethernet/xilinx/xilinx_emacps.c
-+++ b/drivers/net/ethernet/xilinx/xilinx_emacps.c
-@@ -281,6 +281,7 @@ MDC_DIV_64, MDC_DIV_96, MDC_DIV_128, MDC_DIV_224 };
- #define XEMACPS_NWCFG_1000_MASK 0x00000400 /* Gigbit mode */
- #define XEMACPS_NWCFG_EXTADDRMATCHEN_MASK 0x00000200
- /* External address match enable */
-+#define XEMACPS_NWCFG_1536RXEN 0x00000100 /* Receive 1536 Byte frames */
- #define XEMACPS_NWCFG_UCASTHASHEN_MASK 0x00000080 /* Receive unicast hash
- frames */
- #define XEMACPS_NWCFG_MCASTHASHEN_MASK 0x00000040 /* Receive multicast hash
-@@ -1819,6 +1820,7 @@ static void xemacps_init_hw(struct net_local *lp)
- regval |= XEMACPS_NWCFG_PAUSEEN_MASK;
- regval |= XEMACPS_NWCFG_100_MASK;
- regval |= XEMACPS_NWCFG_HDRXEN_MASK;
-+ regval |= XEMACPS_NWCFG_1536RXEN;
-
- regval |= (MDC_DIV_224 << XEMACPS_NWCFG_MDC_SHIFT_MASK);
- if (lp->ndev->flags & IFF_PROMISC) /* copy all */
---
-1.7.10.4
diff --git a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0007-net-phy-disable-buggy-pause-feature-of-micrel-KSZ903.patch b/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0007-net-phy-disable-buggy-pause-feature-of-micrel-KSZ903.patch
deleted file mode 100644
index f88a22c..0000000
--- a/recipes-kernel/linux/linux-xlnx/zx3-zynq7/0007-net-phy-disable-buggy-pause-feature-of-micrel-KSZ903.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 9789fee4dc66b1b945c641fdc044a4c4b406bbd9 Mon Sep 17 00:00:00 2001
-From: David Andrey <david.andrey@netmodule.com>
-Date: Fri, 4 Jul 2014 11:15:11 +0200
-Subject: [PATCH 7/7] net: phy: disable buggy pause feature of micrel KSZ9031
-
-Pause and asychn pause of Micrel KSZ9031 is buggy, so
-do not mark the feature as supported
-
-Signed-off-by: David Andrey <david.andrey@netmodule.com>
----
- drivers/net/phy/micrel.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/net/phy/micrel.c b/drivers/net/phy/micrel.c
-index 412d144..3e2f063 100644
---- a/drivers/net/phy/micrel.c
-+++ b/drivers/net/phy/micrel.c
-@@ -466,8 +466,9 @@ static struct phy_driver ksphy_driver[] = {
- .phy_id = PHY_ID_KSZ9031,
- .phy_id_mask = 0x00fffff0,
- .name = "Micrel KSZ9031 Gigabit PHY",
-- .features = (PHY_GBIT_FEATURES | SUPPORTED_Pause
-- | SUPPORTED_Asym_Pause),
-+ /* @@NetModule AG, da, buggy pause feature, no link can be setup up with it */
-+ .features = (PHY_GBIT_FEATURES /*| SUPPORTED_Pause
-+ | SUPPORTED_Asym_Pause*/),
- .flags = PHY_HAS_MAGICANEG | PHY_HAS_INTERRUPT,
- .config_init = kszphy_config_init,
- .config_aneg = genphy_config_aneg,
---
-1.7.10.4
diff --git a/recipes-kernel/linux/linux-xlnx_3.14.bbappend b/recipes-kernel/linux/linux-xlnx_3.14.bbappend
index 4d8f31d..80efa22 100644
--- a/recipes-kernel/linux/linux-xlnx_3.14.bbappend
+++ b/recipes-kernel/linux/linux-xlnx_3.14.bbappend
@@ -1,31 +1,20 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
### ZE7000 machine configuration ###
-KBRANCH_ze7000-zynq7 = "master"
-SRCREV_ze7000-zynq7 = "f9d391370402f7428cd12e7aaa5c8ab768ba5332"
+KBRANCH_ze7000-zynq7 = "zx3-v3.14"
+SRCREV_ze7000-zynq7 = "4ea440987eb3b5a9cb1f3fd50bb63c86703ef438"
+SRC_URI_ze7000-zynq7 = "git://github.com/netmodule/kernel-zx3.git;protocol=https;branch=${KBRANCH}"
SRC_URI_append_ze7000-zynq7 = " \
- file://zx3-zynq7/0001-zx3-phy-micrel-phy-init.patch \
- file://zx3-zynq7/0002-zx3-phy-adapt-marvell-settings.patch \
- file://zx3-zynq7/0003-zx3-xilinx_emacps-make-phy-address-configurable.patch \
- file://zx3-zynq7/0004-zx3-sdhci-add-sd-card-support.patch \
- file://zx3-zynq7/0005-xilinx_emacps-allow-MTU-of-1500.patch \
- file://zx3-zynq7/0006-xilinx_emacps-Set-the-maximum-frame-reception-size-t.patch \
- file://zx3-zynq7/0007-net-phy-disable-buggy-pause-feature-of-micrel-KSZ903.patch \
file://defconfig \
"
-KBRANCH_zx3-pm3-zynq7 = "master"
-SRCREV_zx3-pm3-zynq7 = "f9d391370402f7428cd12e7aaa5c8ab768ba5332"
+### PM3 machine configuration ###
+KBRANCH_zx3-pm3-zynq7 = "zx3-v3.14"
+SRCREV_zx3-pm3-zynq7 = "4ea440987eb3b5a9cb1f3fd50bb63c86703ef438"
+SRC_URI_zx3-pm3-zynq7 = "git://github.com/netmodule/kernel-zx3.git;protocol=https;branch=${KBRANCH}"
SRC_URI_append_zx3-pm3-zynq7 = " \
- file://zx3-zynq7/0001-zx3-phy-micrel-phy-init.patch \
- file://zx3-zynq7/0002-zx3-phy-adapt-marvell-settings.patch \
- file://zx3-zynq7/0003-zx3-xilinx_emacps-make-phy-address-configurable.patch \
- file://zx3-zynq7/0004-zx3-sdhci-add-sd-card-support.patch \
- file://zx3-zynq7/0005-xilinx_emacps-allow-MTU-of-1500.patch \
- file://zx3-zynq7/0006-xilinx_emacps-Set-the-maximum-frame-reception-size-t.patch \
- file://zx3-zynq7/0007-net-phy-disable-buggy-pause-feature-of-micrel-KSZ903.patch \
file://defconfig \
"