aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/oath
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/oath')
-rw-r--r--recipes-extended/oath/oath/0001-oath-fix-macro-definition-error.patch32
-rw-r--r--recipes-extended/oath/oath_2.6.2.bb19
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes-extended/oath/oath/0001-oath-fix-macro-definition-error.patch b/recipes-extended/oath/oath/0001-oath-fix-macro-definition-error.patch
new file mode 100644
index 00000000..37f9d753
--- /dev/null
+++ b/recipes-extended/oath/oath/0001-oath-fix-macro-definition-error.patch
@@ -0,0 +1,32 @@
+From ba86973a3014caa9a4110611f470d4d9af5c2982 Mon Sep 17 00:00:00 2001
+From: Dengke Du <dengke.du@windriver.com>
+Date: Thu, 27 Sep 2018 09:37:08 +0800
+Subject: [PATCH] oath: fix macro definition error
+
+Signed-off-by: Dengke Du <dengke.du@windriver.com>
+---
+ oathtool/gl/intprops.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/oathtool/gl/intprops.h b/oathtool/gl/intprops.h
+index e1fce5c..cee4997 100644
+--- a/oathtool/gl/intprops.h
++++ b/oathtool/gl/intprops.h
+@@ -230,11 +230,11 @@ verify (TYPE_MAXIMUM (long long int) == LLONG_MAX);
+ (e.g., A and B) have the same type as MIN and MAX. Instead, they assume
+ that the result (e.g., A + B) has that type. */
+ #if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
+-# define _GL_ADD_OVERFLOW(a, b, min, max)
++# define _GL_ADD_OVERFLOW(a, b, min, max) \
+ __builtin_add_overflow (a, b, (__typeof__ ((a) + (b)) *) 0)
+-# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)
++# define _GL_SUBTRACT_OVERFLOW(a, b, min, max) \
+ __builtin_sub_overflow (a, b, (__typeof__ ((a) - (b)) *) 0)
+-# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)
++# define _GL_MULTIPLY_OVERFLOW(a, b, min, max) \
+ __builtin_mul_overflow (a, b, (__typeof__ ((a) * (b)) *) 0)
+ #else
+ # define _GL_ADD_OVERFLOW(a, b, min, max) \
+--
+2.7.4
+
diff --git a/recipes-extended/oath/oath_2.6.2.bb b/recipes-extended/oath/oath_2.6.2.bb
new file mode 100644
index 00000000..f4230449
--- /dev/null
+++ b/recipes-extended/oath/oath_2.6.2.bb
@@ -0,0 +1,19 @@
+LICENSE = "GPLv3 & LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=62e1e33aebac5b1bc9fc48a866e2f61b \
+ file://oathtool/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://liboath/COPYING;md5=4fbd65380cdd255951079008b364516c \
+ file://pam_oath/COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/oath-toolkit/oath-toolkit-${PV}.tar.gz \
+ file://0001-oath-fix-macro-definition-error.patch \
+"
+
+S = "${WORKDIR}/${BPN}-toolkit-${PV}"
+SRC_URI[md5sum] = "4a05cd4768764843bd5493609a6bdb17"
+SRC_URI[sha256sum] = "b03446fa4b549af5ebe4d35d7aba51163442d255660558cd861ebce536824aa0"
+
+inherit autotools
+
+# Specify any options you want to pass to the configure script using EXTRA_OECONF:
+EXTRA_OECONF = ""
+DEPENDS = "gtk-doc-native"