aboutsummaryrefslogtreecommitdiffstats
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf25
1 files changed, 7 insertions, 18 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 53f831e0..dea544fd 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,24 +1,13 @@
# We have a conf and classes directory, add to BBPATH
-BBPATH .= ":${LAYERDIR}:${LAYERDIR}/common"
+BBPATH .= ":${LAYERDIR}"
# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/common/recipes-*/*/*.bb \
- ${LAYERDIR}/common/recipes-*/*/*.bbappend"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
-BBFILE_COLLECTIONS += "intel"
-BBFILE_PATTERN_intel := "^${LAYERDIR}/common/"
-BBFILE_PRIORITY_intel = "5"
+BBFILE_COLLECTIONS += "tlk"
+BBFILE_PATTERN_tlk := "^${LAYERDIR}/"
+BBFILE_PRIORITY_tlk = "5"
-# Additional license directories.
-LICENSE_PATH += "${LAYERDIR}/common/custom-licenses"
+LAYERDEPENDS_tlk = "core intel"
-LAYERDEPENDS_intel = "core"
-LAYERRECOMMENDS_intel = "dpdk intel-qat"
-
-# This should only be incremented on significant changes that will
-# cause compatibility issues with other layers
-LAYERVERSION_intel = "4"
-LAYERSERIES_COMPAT_intel = "rocko"
-
-
-require ${LAYERDIR}/conf/include/maintainers.inc