aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf1
-rw-r--r--meta-dpdk/conf/layer.conf2
-rw-r--r--meta-qat/conf/layer.conf2
-rw-r--r--meta-tlk/conf/layer.conf3
4 files changed, 8 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 40f406d4..53f831e0 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -12,6 +12,7 @@ BBFILE_PRIORITY_intel = "5"
# Additional license directories.
LICENSE_PATH += "${LAYERDIR}/common/custom-licenses"
+LAYERDEPENDS_intel = "core"
LAYERRECOMMENDS_intel = "dpdk intel-qat"
# This should only be incremented on significant changes that will
diff --git a/meta-dpdk/conf/layer.conf b/meta-dpdk/conf/layer.conf
index 5c11debf..61331edc 100644
--- a/meta-dpdk/conf/layer.conf
+++ b/meta-dpdk/conf/layer.conf
@@ -9,6 +9,8 @@ BBFILE_COLLECTIONS += "dpdk"
BBFILE_PATTERN_dpdk := "^${LAYERDIR}/"
BBFILE_PRIORITY_dpdk = "5"
+LAYERDEPENDS_dpdk = "core"
+
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_dpdk = "1"
diff --git a/meta-qat/conf/layer.conf b/meta-qat/conf/layer.conf
index 08921659..2e3aa847 100644
--- a/meta-qat/conf/layer.conf
+++ b/meta-qat/conf/layer.conf
@@ -9,6 +9,8 @@ BBFILE_COLLECTIONS += "intel-qat"
BBFILE_PATTERN_intel-qat := "^${LAYERDIR}/"
BBFILE_PRIORITY_intel-qat = "5"
+LAYERDEPENDS_intel-qat = "core intel"
+
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_intel-qat = "1"
diff --git a/meta-tlk/conf/layer.conf b/meta-tlk/conf/layer.conf
index fc104052..dea544fd 100644
--- a/meta-tlk/conf/layer.conf
+++ b/meta-tlk/conf/layer.conf
@@ -8,3 +8,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "tlk"
BBFILE_PATTERN_tlk := "^${LAYERDIR}/"
BBFILE_PRIORITY_tlk = "5"
+
+LAYERDEPENDS_tlk = "core intel"
+