aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc4
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux_git.bb48
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc31
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb64
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc8
-rw-r--r--recipes-ti/ipc/ti-ipc.inc6
6 files changed, 94 insertions, 67 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index f2df6785..2fb7ffbc 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,5 +1,5 @@
-PV = "3.46.02.04"
-INC_PR = "r1"
+PV = "3.47.00.00"
+INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
new file mode 100644
index 00000000..2340206c
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
+require ti-ipc-examples.inc
+
+DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos"
+
+do_compile_append() {
+
+ if [ "${PLATFORM}" != "UNKNOWN" ]; then
+ oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+ fi
+ oe_runmake -C examples all HOSTOS="linux" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake -C examples all HOSTOS="linux" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ PLATFORM="${ALT_PLATFORM}"
+ fi
+ fi
+}
+
+do_install_append() {
+ cd ${S_ipc-examples}/src
+ IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
+
+ if [ "${PLATFORM}" != "UNKNOWN" ]; then
+ # Install directory for linux examples
+ install -d ${D}${bindir}/ipc/examples
+ oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
+ PLATFORM="${ALT_PLATFORM}"
+ fi
+ fi
+}
+
+FILES_${PN} += "${bindir}/*"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
new file mode 100644
index 00000000..c9fe2cbc
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc-examples.inc
@@ -0,0 +1,31 @@
+HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC"
+require ti-ipc-common.inc
+require ti-ipc-rtos.inc
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02"
+
+INSANE_SKIP_${PN} += "arch"
+
+ALLOW_EMPTY_${PN} = "1"
+
+IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
+
+do_compile() {
+
+ cd ${S_ipc-examples}/src
+ oe_runmake .examples \
+ IPCTOOLS="${S_ipc-metadata}/src/etc"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \
+ IPCTOOLS="${S_ipc-metadata}/src/etc"
+ fi
+}
+
+do_install() {
+ cd ${S_ipc-examples}/src
+ IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
+}
+
+INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 34735d29..d728983e 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -1,80 +1,35 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) examples"
-HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC"
-require ti-ipc-common.inc
-require ti-ipc-rtos.inc
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02"
+DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
+require ti-ipc-examples.inc
DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native"
-INSANE_SKIP_${PN} += "arch"
-
-ALLOW_EMPTY_${PN} = "1"
-
-PACKAGES =+ "${PN}-linux"
-
-INSANE_SKIP_${PN}-linux += "arch"
-ALLOW_EMPTY_${PN}-linux = "1"
-
-IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
-
-do_compile() {
-
- cd ${S_ipc-examples}/src
- oe_runmake .examples \
- IPCTOOLS="${S_ipc-metadata}/src/etc"
+do_compile_append() {
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \
- IPCTOOLS="${S_ipc-metadata}/src/etc"
- echo test
- fi
if [ "${PLATFORM}" != "UNKNOWN" ]; then
oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
if [ ! -z ${ALT_PLATFORM} ]; then
oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \
IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
fi
oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
if [ ! -z ${ALT_PLATFORM} ]; then
oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- PLATFORM="${ALT_PLATFORM}"
- echo testing
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
fi
fi
}
-do_install() {
- cd ${S_ipc-examples}/src
- IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
-
+do_install_append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
# Install directory for bios examples
install -d ${D}/ipc_${IPC_VERSION}/examples/bios
- # Install directory for linux examples
- install -d ${D}${bindir}/ipc/examples
oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
-
if [ ! -z ${ALT_PLATFORM} ]; then
oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
@@ -82,15 +37,8 @@ do_install() {
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
PLATFORM="${ALT_PLATFORM}"
-
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
- PLATFORM="${ALT_PLATFORM}"
fi
fi
}
FILES_${PN} += "ipc_*"
-FILES_${PN}-linux += "${bindir}/*"
-INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index a7c1b3af..57cd1325 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
branch=${TI_IPC_METADATA_GIT_BRANCH};\
name=${TI_IPC_METADATA_NAME}"
-# Corresponds to tag: 3.46.02.04
-SRCREV_ipc-examples = "b833c759d620b4218ece6d64fae91e4777ef823a"
+# Corresponds to tag: 3.47.00.00
+SRCREV_ipc-examples = "e71b82187a324faa9394b83e39495be38255f05b"
-# Corresponds to tag: 3.46.02.04
-SRCREV_ipc-metadata = "afdcf6855f05c97d2bb77867f4f150aed29c1b12"
+# Corresponds to tag: 3.47.00.00
+SRCREV_ipc-metadata = "f026a364d0b9c1aba5c695bf0aac0be8ede95f59"
S_ipc-examples = "${WORKDIR}/git/ipc-examples"
S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index c3742c1b..02f3c8d3 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
TI_IPC_GIT_PROTOCOL = "git"
-TI_IPC_GIT_BRANCH = "3.46"
+TI_IPC_GIT_BRANCH = "3.47"
-#Corresponds to 3.46.02.04
-TI_IPC_SRCREV = "bf355e7d0f5c3993f56a6ea778743b656ef6b536"
+#Corresponds to 3.47.00.00
+TI_IPC_SRCREV = "e576990e3a220ad394b287588c1c7e85e8644d23"
BRANCH = "${TI_IPC_GIT_BRANCH}"
SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"