aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc5
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc6
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb24
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc10
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb20
-rw-r--r--recipes-ti/ipc/ti-ipc.inc4
6 files changed, 35 insertions, 34 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 00e4e915..7f938428 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,5 +1,5 @@
-PV = "3.47.01.00"
-INC_PR = "r1"
+PV = "3.47.02.00"
+INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -15,3 +15,4 @@ PLATFORM_c667x-evm = "C6678"
PLATFORM_c665x-evm = "C6678"
ALT_PLATFORM_k2hk = "TCI6636"
+ALT_PLATFORM_am57xx-evm = "AM572X AM571X"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
index c9fe2cbc..cd2240cd 100644
--- a/recipes-ti/ipc/ti-ipc-examples.inc
+++ b/recipes-ti/ipc/ti-ipc-examples.inc
@@ -17,10 +17,10 @@ do_compile() {
oe_runmake .examples \
IPCTOOLS="${S_ipc-metadata}/src/etc"
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \
+ for alt_platform in ${ALT_PLATFORM}; do
+ oe_runmake .examples "PLATFORM=${alt_platform}" \
IPCTOOLS="${S_ipc-metadata}/src/etc"
- fi
+ done
}
do_install() {
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 8aad69c9..c46e5c81 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -8,16 +8,16 @@ do_compile_append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \
+ for alt_platform in ${ALT_PLATFORM}; do
+ oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- fi
+ done
oe_runmake -C examples all HOSTOS="bios" \
IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- if [ ! -z ${ALT_PLATFORM} ]; then
+ for alt_platform in ${ALT_PLATFORM}; do
oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
- fi
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
+ done
fi
}
@@ -30,14 +30,14 @@ do_install_append() {
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
- if [ ! -z ${ALT_PLATFORM} ]; then
+ for alt_platform in ${ALT_PLATFORM}; do
oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
- PLATFORM="${ALT_PLATFORM}"
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
+ PLATFORM="${alt_platform}"
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
- PLATFORM="${ALT_PLATFORM}"
- fi
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
+ PLATFORM="${alt_platform}"
+ done
fi
}
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 3f876d3f..868743e6 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
branch=${TI_IPC_METADATA_GIT_BRANCH};\
name=${TI_IPC_METADATA_NAME}"
-# Corresponds to tag: 3.47.01.00B
-SRCREV_ipc-examples = "03ff856444b5bb9e60a907125a1f042b29b25d7b"
+# Corresponds to tag: 3.47.02.00
+SRCREV_ipc-metadata = "e8aff83111b8a0d64d7a77413b6f66d3106084d8"
-# Corresponds to tag: 3.47.01.00A
-SRCREV_ipc-metadata = "72578cce9c9f9a932eb22b3397b46131efb12d69"
+# Corresponds to tag: 3.47.02.00
+SRCREV_ipc-examples = "351e9a6d94c68f7ff64b2c002ee6750242ece6d9"
S_ipc-examples = "${WORKDIR}/git/ipc-examples"
S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
@@ -36,7 +36,7 @@ S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
RELEASE_TYPE = "GA"
RELEASE_SUFFIX = ""
-PR = "${INC_PR}.r5"
+PR = "${INC_PR}.r0"
DEPENDS_append_keystone = " ti-cgt6x-native \
gcc-arm-none-eabi-native \
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 53ab76da..b292d677 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -27,20 +27,20 @@ do_compile() {
cd ${S_ipc-examples}/src
oe_runmake .examples \
IPCTOOLS="${S_ipc-metadata}/src/etc"
- if [ ! -z ${ALT_PLATFORM} ]; then
+ for alt_platform in ${ALT_PLATFORM}; do
oe_runmake .examples \
IPCTOOLS="${S_ipc-metadata}/src/etc" \
- PLATFORM=${ALT_PLATFORM}
- fi
+ PLATFORM=${alt_platform}
+ done
if [ "${PLATFORM}" != "UNKNOWN" ]; then
oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}"
oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${S}"
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="bios" IPC_INSTALL_DIR="${S}"
- oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="linux" IPC_INSTALL_DIR="${S}"
- fi
+ for alt_platform in ${ALT_PLATFORM}; do
+ oe_runmake extract PLATFORM=${alt_platform} HOSTOS="bios" IPC_INSTALL_DIR="${S}"
+ oe_runmake extract PLATFORM=${alt_platform} HOSTOS="linux" IPC_INSTALL_DIR="${S}"
+ done
fi
IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
@@ -54,9 +54,9 @@ do_compile() {
cp -pPf ${S_ipc-examples}/src/examples/*.* ${IPC_PACKAGE_DIR}/examples/
cp -pPf ${S_ipc-examples}/src/examples/makefile ${IPC_PACKAGE_DIR}/examples/
cp -pPrf ${S_ipc-examples}/src/examples/${PLATFORM}* ${IPC_PACKAGE_DIR}/examples/
- if [ ! -z ${ALT_PLATFORM} ]; then
- cp -pPrf ${S_ipc-examples}/src/examples/${ALT_PLATFORM}* ${IPC_PACKAGE_DIR}/examples/
- fi
+ for alt_platform in ${ALT_PLATFORM}; do
+ cp -pPrf ${S_ipc-examples}/src/examples/${alt_platform}* ${IPC_PACKAGE_DIR}/examples/
+ done
find ${IPC_PACKAGE_DIR}/examples/ -name "*zip" -type f | xargs -I {} rm {}
fi
}
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index 49d8224f..e8038a56 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -8,8 +8,8 @@ TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
TI_IPC_GIT_PROTOCOL = "git"
TI_IPC_GIT_BRANCH = "3.47"
-#Corresponds to 3.47.01.00
-TI_IPC_SRCREV = "6a2595a4148fb12f259efc19164a9d33ad2ed294"
+#Corresponds to 3.47.02.00
+TI_IPC_SRCREV = "24c36385d096613af123d1e1696fb2fee652ef36"
BRANCH = "${TI_IPC_GIT_BRANCH}"
SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"