aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc5
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc20
-rw-r--r--recipes-ti/ipc/ti-ipc.inc6
-rw-r--r--recipes-ti/ipc/ti-ipc_git.bb1
4 files changed, 22 insertions, 10 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index c5f28e7c..d0f3aa51 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,5 +1,5 @@
-PV = "3.45.00.00"
-INC_PR = "r1"
+PV = "3.46.00.01"
+INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -10,5 +10,6 @@ PLATFORM_k2hk-evm = "TCI6638"
PLATFORM_k2l-evm = "TCI6630"
PLATFORM_k2e = "66AK2E"
PLATFORM_k2g = "66AK2G"
+PLATFORM_omapl138 = "OMAPL138"
ALT_PLATFORM_k2hk-evm = "TCI6636"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index b29e984a..0d7e0e6b 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -28,16 +28,16 @@ name=${TI_IPC_METADATA_NAME}"
# Corresponds to tag: 3.45.00.00
SRCREV_ipc-examples = "3a8ee1841ec36117a9bcd3d45bb2781bbd53ecf8"
-# Corresponds to tag: 3.45.00.00
-SRCREV_ipc-metadata = "30b83f09be1877f86b22c971d978cb478fc7dd6e"
+# Corresponds to tag: 3.46.00.01_eng
+SRCREV_ipc-metadata = "a04b677e9c55bbffd4bd7071ab7dfb6dde3eb97f"
S_ipc-examples = "${WORKDIR}/git/ipc-examples"
S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
-RELEASE_TYPE = "GA"
-RELEASE_SUFFIX = ""
+RELEASE_TYPE = "ENG"
+RELEASE_SUFFIX = "_eng"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.r0"
DEPENDS_append_keystone = " ti-cgt6x-native \
gcc-arm-none-eabi-native \
@@ -46,7 +46,12 @@ DEPENDS_append_omap-a15 = " ti-cgt6x-native \
ti-ccsv6-native \
gcc-arm-none-eabi-native \
"
+DEPENDS_append_omapl138 = " ti-cgt6x-native \
+ gcc-arm-none-eabi-native \
+"
+
IPC_TARGETS = ""
+
IPC_TARGETS_omap-a15 = "\
gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
@@ -54,6 +59,11 @@ IPC_TARGETS_omap-a15 = "\
ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
"
+IPC_TARGETS_omapl138 = "\
+ gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
+ ti.targets.elf.C674="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
+"
+
IPC_TARGETS_keystone = " \
gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index ea256d24..e2a91cf1 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
TI_IPC_GIT_PROTOCOL = "git"
-TI_IPC_GIT_BRANCH = "master"
+TI_IPC_GIT_BRANCH = "3.46"
-#Corresponds to 3.45.00.00
-TI_IPC_SRCREV = "1584985938884bf6cb1d839779578354b1865ea4"
+#Corresponds to 3.46.00.01_eng
+TI_IPC_SRCREV = "a404d6aac840b6170cf4e9d819738842ec91746e"
BRANCH = "${TI_IPC_GIT_BRANCH}"
SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb
index 05b4d85d..ce2eee0a 100644
--- a/recipes-ti/ipc/ti-ipc_git.bb
+++ b/recipes-ti/ipc/ti-ipc_git.bb
@@ -20,6 +20,7 @@ DAEMON_k2hk-evm = "lad_tci6638"
DAEMON_k2l-evm = "lad_tci6630"
DAEMON_k2e = "lad_66ak2e"
DAEMON_k2g = "lad_66ak2g"
+DAEMON_omapl138 = "lad_omapl138"
inherit autotools-brokensep pkgconfig update-rc.d