aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r--recipes-ti/ipc/ipc-transport-common-rtos_git.bb23
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb23
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss-test_git.bb37
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss.inc14
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss_git.bb19
-rw-r--r--recipes-ti/ipc/ipc-transport-srio-rtos_git.bb22
-rw-r--r--recipes-ti/ipc/ipc-transport-srio-test_git.bb32
-rw-r--r--recipes-ti/ipc/ipc-transport-srio.inc14
-rw-r--r--recipes-ti/ipc/ipc-transport-srio_git.bb19
-rw-r--r--recipes-ti/ipc/ipc-transport.inc15
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc20
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux_git.bb47
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc31
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb44
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc88
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb124
-rw-r--r--recipes-ti/ipc/ti-ipc.inc18
-rw-r--r--recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch112
-rw-r--r--recipes-ti/ipc/ti-ipc/omap_remoteproc.conf1
-rw-r--r--recipes-ti/ipc/ti-ipc/tiipclad-daemon.service9
-rw-r--r--recipes-ti/ipc/ti-ipc/tiipclad-daemon.sh25
-rw-r--r--recipes-ti/ipc/ti-ipc_git.bb68
22 files changed, 0 insertions, 805 deletions
diff --git a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb
deleted file mode 100644
index 6fec0f0d..00000000
--- a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-require recipes-ti/includes/ti-paths.inc
-require ipc-transport.inc
-
-PR = "${INC_PR}.1"
-
-LIC_FILES_CHKSUM = "file://common_src/bench_common.h;beginline=1;endline=31;md5=a6ddfb26d2097041d513e3881f40e4e8"
-
-COMPATIBLE_MACHINE = "k2hk|k2l|k2e"
-
-IPC_TRANSPORT_COMMON_DESTSUFFIX = "git/c66/example"
-
-S = "${WORKDIR}/${IPC_TRANSPORT_COMMON_DESTSUFFIX}"
-
-do_compile() {
- :
-}
-
-do_install () {
- install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example
- cp -r ${S} ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66
-}
-
-FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example/*"
diff --git a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb
deleted file mode 100644
index 6655ab7e..00000000
--- a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-inherit ti-pdk
-require ipc-transport.inc
-
-PR = "${INC_PR}.4"
-
-LIC_FILES_CHKSUM = "file://TransportQmss.xdc;beginline=1;endline=35;md5=ad783760d74a4cc5b8d4ad3d8a1f28a2"
-
-COMPATIBLE_MACHINE = "k2hk|k2l|k2e"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS_append = " qmss-lld-rtos \
- cppi-lld-rtos \
- ti-ipc-rtos \
- ipc-transport-common-rtos \
-"
-
-IPC_TRANSPORT_QMSS_DESTSUFFIX = "git/c66/qmss"
-
-S = "${WORKDIR}/${IPC_TRANSPORT_QMSS_DESTSUFFIX}"
-
-export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}"
-XDCPATH_append = ";${IPC_INSTALL_DIR}/packages"
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
deleted file mode 100644
index 3561ef95..00000000
--- a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-include ipc-transport-qmss.inc
-
-PR = "${INC_PR}.0"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS = "ipc-transport-qmss ti-ipc"
-
-#FILES_${PN}-test = "${bindir}/multiProcessTest_*.out"
-
-CHOICELIST = "yes no"
-
-DEVICELIST_k2hk = "k2h k2k"
-DEVICELIST_k2e = "k2e"
-DEVICELIST_k2l = "k2l"
-
-do_compile () {
-# Now build the test code
- for device in ${DEVICELIST}
- do
- for choice in ${CHOICELIST}
- do
- oe_runmake tests \
- IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \
- USEDYNAMIC_LIB="$choice" DEVICE="$device"
- done
- done
-}
-
-do_install () {
- for device in ${DEVICELIST}
- do
- oe_runmake installbin \
- INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
- done
-
-}
diff --git a/recipes-ti/ipc/ipc-transport-qmss.inc b/recipes-ti/ipc/ipc-transport-qmss.inc
deleted file mode 100644
index f029656e..00000000
--- a/recipes-ti/ipc/ipc-transport-qmss.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "TI QMSS-Based IPC MessageQ Transport"
-LICENSE = "BSD-3-Clause"
-
-require ipc-transport.inc
-
-INC_PR_append = ".1"
-
-LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02"
-
-COMPATIBLE_MACHINE = "keystone"
-
-S = "${WORKDIR}/git/linux/qmss"
-
-EXTRA_OEMAKE += "PDK_INSTALL_PATH=${STAGING_INCDIR} TRANS_QMSS_SRC_DIR=${S}"
diff --git a/recipes-ti/ipc/ipc-transport-qmss_git.bb b/recipes-ti/ipc/ipc-transport-qmss_git.bb
deleted file mode 100644
index 93136670..00000000
--- a/recipes-ti/ipc/ipc-transport-qmss_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-include ipc-transport-qmss.inc
-
-PR = "${INC_PR}.0"
-
-DEPENDS = "ti-ipc mpm-transport"
-
-do_compile () {
-# Now build the transport
- oe_runmake clean
- oe_runmake lib
-}
-
-do_install () {
- oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \
- INSTALL_LIB_BASE_DIR=${D}${libdir}
- chown -R root:root ${D}
-}
-
-INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/libTransportQmss.a"
diff --git a/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb b/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb
deleted file mode 100644
index 3f96598f..00000000
--- a/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-inherit ti-pdk
-require ipc-transport.inc
-
-PR = "${INC_PR}.2"
-
-LIC_FILES_CHKSUM = "file://TransportSrio.xdc;beginline=1;endline=35;md5=4d466471e4b933a0cc353a46bb546fe7"
-
-COMPATIBLE_MACHINE = "k2hk"
-
-DEPENDS_append = " qmss-lld-rtos \
- cppi-lld-rtos \
- srio-lld-rtos \
- ti-ipc-rtos \
- ipc-transport-common-rtos \
-"
-
-IPC_TRANSPORT_SRIO_DESTSUFFIX = "git/c66/srio"
-
-S = "${WORKDIR}/${IPC_TRANSPORT_SRIO_DESTSUFFIX}"
-
-export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}"
-XDCPATH_append = ";${IPC_INSTALL_DIR}/packages"
diff --git a/recipes-ti/ipc/ipc-transport-srio-test_git.bb b/recipes-ti/ipc/ipc-transport-srio-test_git.bb
deleted file mode 100644
index 4e23fb21..00000000
--- a/recipes-ti/ipc/ipc-transport-srio-test_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-include ipc-transport-srio.inc
-
-PR = "${INC_PR}.0"
-
-DEPENDS = "ipc-transport-srio ipc-transport-qmss ti-ipc"
-
-DEVICELIST = "k2h k2k"
-
-CHOICELIST = "yes no"
-
-do_compile () {
-# Now build the test code
- for device in ${DEVICELIST}
- do
- for choice in ${CHOICELIST}
- do
- oe_runmake tests \
- IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \
- USEDYNAMIC_LIB="$choice" DEVICE="$device"
- done
- done
-}
-
-do_install () {
-
- for device in ${DEVICELIST}
- do
- oe_runmake installbin \
- INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
- done
-
-}
diff --git a/recipes-ti/ipc/ipc-transport-srio.inc b/recipes-ti/ipc/ipc-transport-srio.inc
deleted file mode 100644
index 6c477388..00000000
--- a/recipes-ti/ipc/ipc-transport-srio.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "TI SRIO-Based IPC MessageQ Transport"
-LICENSE = "BSD-3-Clause"
-
-require ipc-transport.inc
-
-INC_PR_append = ".1"
-
-LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02"
-
-COMPATIBLE_MACHINE = "k2hk"
-
-S = "${WORKDIR}/git/linux/srio"
-
-EXTRA_OEMAKE += "PDK_INSTALL_PATH=${STAGING_INCDIR} TRANS_SRIO_SRC_DIR=${S}"
diff --git a/recipes-ti/ipc/ipc-transport-srio_git.bb b/recipes-ti/ipc/ipc-transport-srio_git.bb
deleted file mode 100644
index 6001585a..00000000
--- a/recipes-ti/ipc/ipc-transport-srio_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-include ipc-transport-srio.inc
-
-PR = "${INC_PR}.0"
-
-DEPENDS = "ti-ipc mpm-transport"
-
-do_compile () {
-# Now build the transport
- oe_runmake clean
- oe_runmake lib
-}
-
-do_install () {
- oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \
- INSTALL_LIB_BASE_DIR=${D}${libdir}
- chown -R root:root ${D}
-}
-
-INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/libTransportSrio.a"
diff --git a/recipes-ti/ipc/ipc-transport.inc b/recipes-ti/ipc/ipc-transport.inc
deleted file mode 100644
index 0c1edef1..00000000
--- a/recipes-ti/ipc/ipc-transport.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-LICENSE = "BSD-3-Clause"
-
-IPC_TRANSPORT_GIT_URI = "git://git.ti.com/keystone-linux/ipc-transport.git"
-IPC_TRANSPORT_GIT_PROTOCOL = "git"
-IPC_TRANSPORT_GIT_BRANCH = "master"
-
-# Below commit ID corresponds to "DEV.IPC-TRANSPORT.02.00.00.02A"
-IPC_TRANSPORT_SRCREV = "f75e2e29b9b1b63443a0c82493e41dd2f771c6f5"
-
-BRANCH = "${IPC_TRANSPORT_GIT_BRANCH}"
-SRC_URI = "${IPC_TRANSPORT_GIT_URI};protocol=${IPC_TRANSPORT_GIT_PROTOCOL};branch=${BRANCH}"
-
-SRCREV = "${IPC_TRANSPORT_SRCREV}"
-PV = "02.00.00.02A"
-INC_PR = "r0"
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
deleted file mode 100644
index 449903f1..00000000
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ /dev/null
@@ -1,20 +0,0 @@
-PV = "3.51.00.00"
-INC_PR = "r0"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_HOST ?= "null"
-COMPATIBLE_HOST_ti-soc = "(.*)"
-
-PLATFORM = "UNKNOWN"
-PLATFORM_omap5-evm = "OMAP54XX"
-PLATFORM_dra7xx = "DRA7XX"
-PLATFORM_k2hk = "TCI6638"
-PLATFORM_k2l = "TCI6630"
-PLATFORM_k2e = "66AK2E"
-PLATFORM_k2g = "66AK2G"
-PLATFORM_omapl138 = "OMAPL138"
-PLATFORM_c667x-evm = "C6678"
-PLATFORM_c665x-evm = "C6678"
-
-ALT_PLATFORM_k2hk = "TCI6636"
-ALT_PLATFORM_am57xx-evm = "AM572X AM571X"
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
deleted file mode 100644
index 471d7ff2..00000000
--- a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
-require ti-ipc-examples.inc
-
-DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
-
-do_compile_append() {
-
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
-
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- fi
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
-
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- PLATFORM="${ALT_PLATFORM}"
- fi
- fi
-}
-
-do_install_append() {
- cd ${S_ipc-examples}/src
-
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- # Install directory for linux examples
- install -d ${D}${bindir}/ipc/examples
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
-
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
- PLATFORM="${ALT_PLATFORM}"
- fi
- fi
-}
-
-FILES_${PN} += "${bindir}/*"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
deleted file mode 100644
index 022b13f0..00000000
--- a/recipes-ti/ipc/ti-ipc-examples.inc
+++ /dev/null
@@ -1,31 +0,0 @@
-HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC"
-require ti-ipc-common.inc
-require ti-ipc-rtos.inc
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=a52324bd5033bb49ea07bade1244ac9a"
-
-INSANE_SKIP_${PN} += "arch"
-
-ALLOW_EMPTY_${PN} = "1"
-
-IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
-
-do_compile() {
-
- cd ${S_ipc-examples}/src
- oe_runmake .examples \
- IPCTOOLS="${S_ipc-metadata}/src/etc"
-
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake .examples "PLATFORM=${alt_platform}" \
- IPCTOOLS="${S_ipc-metadata}/src/etc"
- done
-}
-
-do_install() {
- cd ${S_ipc-examples}/src
- IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
-}
-
-INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
deleted file mode 100644
index c46e5c81..00000000
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
-require ti-ipc-examples.inc
-
-DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
-
-do_compile_append() {
-
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
-
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- done
- oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
- done
- fi
-}
-
-do_install_append() {
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- # Install directory for bios examples
- install -d ${D}/ipc_${IPC_VERSION}/examples/bios
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
- oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
-
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
- PLATFORM="${alt_platform}"
- oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
- PLATFORM="${alt_platform}"
- done
- fi
-}
-
-FILES_${PN} += "ipc_*"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
deleted file mode 100644
index b6b7892f..00000000
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ /dev/null
@@ -1,88 +0,0 @@
-require recipes-ti/includes/ti-paths.inc
-
-TI_IPC_EXAMPLES_GIT_URI = "git://git.ti.com/ipc/ipc-examples.git"
-TI_IPC_EXAMPLES_DEST_SUFFIX = "git/ipc-examples"
-TI_IPC_EXAMPLES_GIT_PROTOCOL = "git"
-TI_IPC_EXAMPLES_GIT_BRANCH = "master"
-TI_IPC_EXAMPLES_NAME = "ipc-examples"
-
-SRC_URI += "${TI_IPC_EXAMPLES_GIT_URI};\
-destsuffix=${TI_IPC_EXAMPLES_DEST_SUFFIX};\
-protocol=${TI_IPC_EXAMPLES_GIT_PROTOCOL};\
-branch=${TI_IPC_EXAMPLES_GIT_BRANCH};\
-name=${TI_IPC_EXAMPLES_NAME}"
-
-TI_IPC_METADATA_GIT_URI = "git://git.ti.com/ipc/ipc-metadata.git"
-TI_IPC_METADATA_DEST_SUFFIX = "git/ipc-metadata"
-TI_IPC_METADATA_GIT_PROTOCOL = "git"
-TI_IPC_METADATA_GIT_BRANCH = "master"
-TI_IPC_METADATA_NAME = "ipc-metadata"
-
-SRC_URI += "${TI_IPC_METADATA_GIT_URI};\
-destsuffix=${TI_IPC_METADATA_DEST_SUFFIX};\
-protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
-branch=${TI_IPC_METADATA_GIT_BRANCH};\
-name=${TI_IPC_METADATA_NAME}"
-
-# Corresponds to tag: 3.51.00.00
-TI_IPC_METADATA_SRCREV = "1bf668fd6b0ec2ef6956fa55b8484d0b21a9f9e2"
-# Corresponds to tag: 3.51.00.00
-TI_IPC_EXAMPLES_SRCREV = "4707fcbbe0d136e781c4a7ffdc072be407c34358"
-
-SRCREV_FORMAT = "default"
-SRCREV_ipc-metadata = "${TI_IPC_METADATA_SRCREV}"
-SRCREV_ipc-examples = "${TI_IPC_EXAMPLES_SRCREV}"
-
-S_ipc-examples = "${WORKDIR}/git/ipc-examples"
-S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
-
-RELEASE_TYPE = "GA"
-RELEASE_SUFFIX = ""
-
-PR = "${INC_PR}.r0"
-
-DEPENDS_append_keystone = " ti-cgt6x-native \
- gcc-arm-baremetal-native \
-"
-DEPENDS_append_omap-a15 = " ti-cgt6x-native \
- ti-cgt-arm-native \
- gcc-arm-baremetal-native \
-"
-DEPENDS_append_omapl138 = " ti-cgt6x-native \
-"
-DEPENDS_append_c66x = " ti-cgt6x-native \
-"
-
-IPC_TARGETS = ""
-
-IPC_TARGETS_omap-a15 = "\
- gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
- ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
- ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
- ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
-"
-
-IPC_TARGETS_omapl138 = "\
- ti.targets.elf.C674="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
-"
-
-IPC_TARGETS_keystone = " \
- gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
- ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
- ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
-"
-IPC_TARGETS_c66x = " \
- ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
- ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
-"
-
-PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}"
-EXTRA_OEMAKE = "\
- PLATFORM=${PLATFORM} \
- XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
- BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \
- ${IPC_TARGETS} \
- ${PARALLEL_XDC} \
- JAVA_TOOL_OPTIONS=-Xss2560k \
-"
-
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
deleted file mode 100644
index b292d677..00000000
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ /dev/null
@@ -1,124 +0,0 @@
-require ti-ipc.inc
-require ti-ipc-common.inc
-require ti-ipc-rtos.inc
-
-DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native"
-
-PACKAGES =+ "${PN}-fw"
-FILES_${PN}-fw = "${base_libdir}/firmware/*"
-FILES_${PN}-dev += "${IPC_INSTALL_DIR_RECIPE}"
-
-INSANE_SKIP_${PN}-fw += "arch"
-INSANE_SKIP_${PN}-dev += "arch"
-
-ALLOW_EMPTY_${PN} = "1"
-
-IPC_PACKAGE_DIR = "${S}/ipc-package"
-
-do_compile() {
- oe_runmake -f ipc-bios.mak clean
- oe_runmake -f ipc-bios.mak release
-
- cd ${S_ipc-metadata}
- oe_runmake .all-files IPC_INSTALL_DIR="${S}" \
- BUILD_HOST_OS="linux" \
- RELEASE_TYPE="${RELEASE_TYPE}"
-
- cd ${S_ipc-examples}/src
- oe_runmake .examples \
- IPCTOOLS="${S_ipc-metadata}/src/etc"
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake .examples \
- IPCTOOLS="${S_ipc-metadata}/src/etc" \
- PLATFORM=${alt_platform}
- done
-
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}"
- oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${S}"
-
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake extract PLATFORM=${alt_platform} HOSTOS="bios" IPC_INSTALL_DIR="${S}"
- oe_runmake extract PLATFORM=${alt_platform} HOSTOS="linux" IPC_INSTALL_DIR="${S}"
- done
- fi
-
- IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
- install -d ${IPC_PACKAGE_DIR}
- # Copy docs and other meta files
- cp -pPrf ${S_ipc-metadata}/exports/ipc_${IPC_VERSION}/* -d ${IPC_PACKAGE_DIR}
-
- # Copy example folders corresponding to the platforms
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- install -d ${IPC_PACKAGE_DIR}/examples
- cp -pPf ${S_ipc-examples}/src/examples/*.* ${IPC_PACKAGE_DIR}/examples/
- cp -pPf ${S_ipc-examples}/src/examples/makefile ${IPC_PACKAGE_DIR}/examples/
- cp -pPrf ${S_ipc-examples}/src/examples/${PLATFORM}* ${IPC_PACKAGE_DIR}/examples/
- for alt_platform in ${ALT_PLATFORM}; do
- cp -pPrf ${S_ipc-examples}/src/examples/${alt_platform}* ${IPC_PACKAGE_DIR}/examples/
- done
- find ${IPC_PACKAGE_DIR}/examples/ -name "*zip" -type f | xargs -I {} rm {}
- fi
-}
-
-do_install() {
- CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
- IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
- # Copy docs and other meta files
- install -d ${D}${IPC_INSTALL_DIR_RECIPE}
- cp ${CP_ARGS} ${IPC_PACKAGE_DIR}/* -d ${D}${IPC_INSTALL_DIR_RECIPE}
-
- install -d ${D}${base_libdir}/firmware/ipc
- cp ${CP_ARGS} ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc || true
-}
-
-KFDSPNUM = "0"
-KFDSPNUM_k2hk = "8"
-KFDSPNUM_k2l = "4"
-KFDSPNUM_keystone = "1"
-
-KFPLAT = ""
-KFPLAT_k2hk = "TCI6638K2K"
-KFPLAT_k2l = "TCI6630K2L"
-KFPLAT_k2e = "C66AK2E"
-KFPLAT_k2g = "TCI66AK2G02"
-
-ALTERNATIVE_PRIORITY = "5"
-
-pkg_postinst_${PN}-fw_keystone () {
- i=0
- while [ $i -lt ${KFDSPNUM} ]; do
- update-alternatives --install /lib/firmware/keystone-dsp$i-fw keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66 ${ALTERNATIVE_PRIORITY}
- i=$(($i + 1))
- done
-}
-
-pkg_postrm_${PN}-fw_keystone () {
- i=0
- while [ $i -lt ${KFDSPNUM} ]; do
- update-alternatives --remove keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66
- i=$(($i + 1))
- done
-}
-
-pkg_postinst_${PN}-fw_omap-a15 () {
- update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY}
- update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY}
- update-alternatives --install /lib/firmware/dra7-ipu1-fw.xem4 dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4 ${ALTERNATIVE_PRIORITY}
- update-alternatives --install /lib/firmware/dra7-ipu2-fw.xem4 dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4 ${ALTERNATIVE_PRIORITY}
-}
-
-pkg_postrm_${PN}-fw_omap-a15 () {
- update-alternatives --remove dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66
- update-alternatives --remove dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66
- update-alternatives --remove dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4
- update-alternatives --remove dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4
-}
-
-pkg_postinst_${PN}-fw_omapl138 () {
- update-alternatives --install /lib/firmware/rproc-dsp-fw rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 ${ALTERNATIVE_PRIORITY}
-}
-
-pkg_postrm_${PN}-fw_omapl138 () {
- update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674
-}
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
deleted file mode 100644
index 3b0115eb..00000000
--- a/recipes-ti/ipc/ti-ipc.inc
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
-HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9b710fd7c95e545b91cec79255"
-
-TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
-TI_IPC_GIT_PROTOCOL = "git"
-TI_IPC_GIT_BRANCH = "master"
-
-#Corresponds to 3.51.00.00A
-TI_IPC_SRCREV = "7a6e343a208d2849139b7272a67abc01db806e00"
-
-BRANCH = "${TI_IPC_GIT_BRANCH}"
-SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"
-SRCREV = "${TI_IPC_SRCREV}"
-
-S = "${WORKDIR}/git"
diff --git a/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch b/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch
deleted file mode 100644
index 71d5b2be..00000000
--- a/recipes-ti/ipc/ti-ipc/0001-Add-kernel-build-dir.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-From c3ada6bf49e6fcf7bc49e5bf09754f384838ca6a Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Mon, 27 Jul 2015 11:51:52 -0400
-Subject: [PATCH] Add kernel build dir
-
-We build kernel outside of the source directory and the generated version.h
-file ends up being in a separate directory from the rest of kernel headers.
-Use another variable to point to the kernel build artifacts.
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-
----
- configure.ac | 6 ++++++
- ipc-linux.mak | 3 +++
- linux/src/mm/Makefile.am | 2 +-
- packages/ti/ipc/mm/MmRpc.c | 4 ++++
- 4 files changed, 14 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 4d4a559..84ac78b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -71,6 +71,7 @@ AC_SUBST([AM_LDFLAGS])
- AC_ARG_VAR(PLATFORM, Platform to build. Options are: 'OMAPL138' 'OMAP54XX' '66AK2E' 'TCI6630' 'TCI6636' 'TCI6638' '66AK2G' 'DRA7XX' and 'AM65XX'. If not defined all platforms will be built.)
- AC_ARG_VAR(CMEM_INSTALL_DIR, Installation path directory to the CMEM libraries)
- AC_ARG_VAR(KERNEL_INSTALL_DIR, Installation path to the Linux kernel.)
-+AC_ARG_VAR(KERNEL_BUILD_DIR, Path to the Linux kernel build artifacts.)
- AC_ARG_VAR(AF_RPMSG, Address Family used by the RPMSG driver)
- AC_ARG_VAR(DRM_PREFIX, Installation location to the DRM library.)
-
-@@ -113,6 +114,7 @@ AS_IF([test "x$PLATFORM" = "x"], [CMEM_INSTALL_DIR=])
- AC_SUBST([PLATFORM])
- AC_SUBST([CMEM_INSTALL_DIR])
- AC_SUBST([KERNEL_INSTALL_DIR])
-+AC_SUBST([KERNEL_BUILD_DIR])
- AC_SUBST([AF_RPMSG])
- AC_SUBST([DRM_PREFIX])
-
-@@ -130,6 +132,7 @@ AM_CONDITIONAL([AM65XX], [test "x$PLATFORM" = "xAM65XX"])
- AM_CONDITIONAL([CMEM], [test "x$CMEM_INSTALL_DIR" != "x"])
- AM_CONDITIONAL([KDIR], [test "x$KERNEL_INSTALL_DIR" != "x"])
- AM_CONDITIONAL([KERNEL_INSTALL_DIR], [test -n "$KERNEL_INSTALL_DIR"])
-+AM_CONDITIONAL([KERNEL_BUILD_DIR], [test -n "$KERNEL_BUILD_DIR"])
- AM_CONDITIONAL([DRM], [test "x$DRM_PREFIX" != "x"])
- AM_CONDITIONAL([AF_RPMSG], [test -n "$AF_RPMSG"])
-
-@@ -160,6 +163,9 @@ You have configured to build for the '${PLATFORM}' platform
- Your KERNEL installation directory is set to:
- '${KERNEL_INSTALL_DIR}'
-
-+Your KERNEL build artifacts directory is set to:
-+ '${KERNEL_BUILD_DIR}'
-+
- Your DRM installation directory is set to:
- '${DRM_PREFIX}'
-
-diff --git a/ipc-linux.mak b/ipc-linux.mak
-index 58a9cea..4e543ff 100644
---- a/ipc-linux.mak
-+++ b/ipc-linux.mak
-@@ -60,6 +60,7 @@ config:
- PLATFORM=$(PLATFORM) \
- CMEM_INSTALL_DIR=$(CMEM_INSTALL_DIR) \
- KERNEL_INSTALL_DIR=$(KERNEL_INSTALL_DIR) \
-+ KERNEL_BUILD_DIR=$(KERNEL_BUILD_DIR) \
- DRM_PREFIX=$(DRM_PREFIX) \
- AF_RPMSG=$(AF_RPMSG)
-
-@@ -72,6 +73,7 @@ config-static:
- PLATFORM=$(PLATFORM) \
- CMEM_INSTALL_DIR=$(CMEM_INSTALL_DIR) \
- KERNEL_INSTALL_DIR=$(KERNEL_INSTALL_DIR) \
-+ KERNEL_BUILD_DIR=$(KERNEL_BUILD_DIR) \
- DRM_PREFIX=$(DRM_PREFIX) \
- AF_RPMSG=$(AF_RPMSG)
-
-@@ -84,5 +86,6 @@ config-shared:
- PLATFORM=$(PLATFORM) \
- CMEM_INSTALL_DIR=$(CMEM_INSTALL_DIR) \
- KERNEL_INSTALL_DIR=$(KERNEL_INSTALL_DIR) \
-+ KERNEL_BUILD_DIR=$(KERNEL_BUILD_DIR) \
- DRM_PREFIX=$(DRM_PREFIX) \
- AF_RPMSG=$(AF_RPMSG)
-diff --git a/linux/src/mm/Makefile.am b/linux/src/mm/Makefile.am
-index 59aa312..8fb51a3 100644
---- a/linux/src/mm/Makefile.am
-+++ b/linux/src/mm/Makefile.am
-@@ -32,7 +32,7 @@
- ##
-
- # additional include paths necessary to compile the library
--AM_CFLAGS = -Wall @AM_CFLAGS@ -DKERNEL_INSTALL_DIR="$(KERNEL_INSTALL_DIR)"
-+AM_CFLAGS = -Wall @AM_CFLAGS@ -DKERNEL_INSTALL_DIR="$(KERNEL_INSTALL_DIR)" -DKERNEL_BUILD_DIR="$(KERNEL_BUILD_DIR)"
-
- ###############################################################################
- # THE LIBRARIES TO BUILD
-diff --git a/packages/ti/ipc/mm/MmRpc.c b/packages/ti/ipc/mm/MmRpc.c
-index 2df7420..797e100 100644
---- a/packages/ti/ipc/mm/MmRpc.c
-+++ b/packages/ti/ipc/mm/MmRpc.c
-@@ -56,7 +56,11 @@
- #endif
-
- #define linux_version_include(kd) <kd/include/generated/uapi/linux/version.h>
-+#if defined(KERNEL_BUILD_DIR)
-+#include linux_version_include(KERNEL_BUILD_DIR)
-+#else
- #include linux_version_include(KERNEL_INSTALL_DIR)
-+#endif
-
- #if LINUX_VERSION_CODE < KERNEL_VERSION(3,14,0)
- #define linux_include(kd,m) <kd/include/linux/m.h>
diff --git a/recipes-ti/ipc/ti-ipc/omap_remoteproc.conf b/recipes-ti/ipc/ti-ipc/omap_remoteproc.conf
deleted file mode 100644
index 6b5034cd..00000000
--- a/recipes-ti/ipc/ti-ipc/omap_remoteproc.conf
+++ /dev/null
@@ -1 +0,0 @@
-softdep omap_remoteproc pre: virtio_rpmsg_bus
diff --git a/recipes-ti/ipc/ti-ipc/tiipclad-daemon.service b/recipes-ti/ipc/ti-ipc/tiipclad-daemon.service
deleted file mode 100644
index ea26845e..00000000
--- a/recipes-ti/ipc/ti-ipc/tiipclad-daemon.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=TI IPC Daemon
-
-[Service]
-Type=forking
-ExecStart=/usr/bin/__LAD_DAEMON__ -g -l lad.txt
-
-[Install]
-WantedBy=basic.target
diff --git a/recipes-ti/ipc/ti-ipc/tiipclad-daemon.sh b/recipes-ti/ipc/ti-ipc/tiipclad-daemon.sh
deleted file mode 100644
index 9ebfa35a..00000000
--- a/recipes-ti/ipc/ti-ipc/tiipclad-daemon.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#! /bin/sh
-
-tiipclad_daemon=/usr/bin/__LAD_DAEMON__
-tiipclad_params="-g -l lad.txt"
-
-test -x "$tiipclad_daemon" || exit 0
-
-case "$1" in
- start)
- echo -n "Starting tiipclad daemon"
- start-stop-daemon --start --quiet \
- --exec $tiipclad_daemon -- $tiipclad_params
- echo "."
- ;;
- stop)
- echo -n "Stopping tiipclad daemon"
- start-stop-daemon --stop --quiet --pidfile /var/run/tiipclad.pid
- echo "."
- ;;
- *)
- echo "Usage: /etc/init.d/tiipclad-daemon.sh {start|stop}"
- exit 1
-esac
-
-exit 0
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb
deleted file mode 100644
index 425ca4e1..00000000
--- a/recipes-ti/ipc/ti-ipc_git.bb
+++ /dev/null
@@ -1,68 +0,0 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
-HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
-
-require ti-ipc.inc
-require ti-ipc-common.inc
-
-PR = "${INC_PR}.2"
-
-DEPENDS += "virtual/kernel"
-
-SRC_URI += "file://tiipclad-daemon.sh \
- file://omap_remoteproc.conf \
- file://tiipclad-daemon.service \
- file://0001-Add-kernel-build-dir.patch \
- "
-
-DAEMON = "UNKNOWN"
-DAEMON_omap5-evm = "lad_omap54xx_smp"
-DAEMON_dra7xx = "lad_dra7xx"
-DAEMON_k2hk = "lad_tci6638"
-DAEMON_k2l = "lad_tci6630"
-DAEMON_k2e = "lad_66ak2e"
-DAEMON_k2g = "lad_66ak2g"
-DAEMON_omapl138 = "lad_omapl138"
-
-inherit autotools-brokensep pkgconfig update-rc.d systemd
-
-INITSCRIPT_NAME = "tiipclad-daemon.sh"
-INITSCRIPT_PARAMS = "defaults 10"
-
-SYSTEMD_SERVICE_${PN} = "tiipclad-daemon.service"
-
-EXTRA_OECONF += "PLATFORM=${PLATFORM} KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR} KERNEL_BUILD_DIR=${STAGING_KERNEL_BUILDDIR}"
-
-do_compile[depends] += "virtual/kernel:do_shared_workdir"
-
-do_configure() {
- ( cd ${S}; autoreconf -f -i -s )
- oe_runconf
-}
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
-
- # Modify the startup scripts to point to the right
- # lad daemon executable.
- sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.sh
- sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.service
-
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/tiipclad-daemon.service ${D}${systemd_system_unitdir}
- install -d ${D}${sysconfdir}/init.d/
- install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
-}
-
-do_install_append_dra7xx() {
- install -d ${D}${sysconfdir}/modprobe.d/
- install -c -m 644 ${WORKDIR}/omap_remoteproc.conf ${D}${sysconfdir}/modprobe.d/
-}
-
-PACKAGES =+ "${PN}-test"
-RDEPENDS_${PN}-test += "${PN}"
-
-FILES_${PN}-test = " \
- ${bindir}/NameServerApp \
- ${bindir}/MessageQApp \
- ${bindir}/MessageQMulti \
- ${bindir}/ping_rpmsg"