aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-examples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-examples_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 8aad69c9..c46e5c81 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -8,16 +8,16 @@ do_compile_append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \
+ for alt_platform in ${ALT_PLATFORM}; do
+ oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- fi
+ done
oe_runmake -C examples all HOSTOS="bios" \
IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- if [ ! -z ${ALT_PLATFORM} ]; then
+ for alt_platform in ${ALT_PLATFORM}; do
oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
- fi
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
+ done
fi
}
@@ -30,14 +30,14 @@ do_install_append() {
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
- if [ ! -z ${ALT_PLATFORM} ]; then
+ for alt_platform in ${ALT_PLATFORM}; do
oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
- PLATFORM="${ALT_PLATFORM}"
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
+ PLATFORM="${alt_platform}"
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
- PLATFORM="${ALT_PLATFORM}"
- fi
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
+ PLATFORM="${alt_platform}"
+ done
fi
}