aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/framework-components
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/framework-components')
-rw-r--r--recipes-ti/framework-components/ti-framework-components.inc21
-rw-r--r--recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb8
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-ti/framework-components/ti-framework-components.inc b/recipes-ti/framework-components/ti-framework-components.inc
new file mode 100644
index 00000000..f2244db4
--- /dev/null
+++ b/recipes-ti/framework-components/ti-framework-components.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "TI Framework Components"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc"
+SECTION = "devel"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://framework_components_2_26_00_01_manifest.html;md5=3250f9da7ee72284c07f8dd840400c75"
+
+require recipes-ti/includes/ti-paths.inc
+require recipes-ti/includes/ti-staging.inc
+
+PR = "r1"
+
+S = "${WORKDIR}/framework_components_${PV}"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball"
+
+do_install() {
+ install -d ${D}${FC_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${FC_INSTALL_DIR_RECIPE}
+}
+
diff --git a/recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb b/recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb
new file mode 100644
index 00000000..b7ea9b83
--- /dev/null
+++ b/recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb
@@ -0,0 +1,8 @@
+require ti-framework-components.inc
+
+PV = "2_26_00_01"
+
+SRC_URI[fctarball.md5sum] = "40b51cade2f9ae6e6f6dca73c17065af"
+SRC_URI[fctarball.sha256sum] = "3f7a12a51dfe87310828a31518d7ef8f9039e59269c0ca24f74a68433c235048"
+
+