aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/devtools/ti-cg-xml_2.41.00.bb')
-rw-r--r--recipes-ti/devtools/ti-cg-xml_2.41.00.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
index 115254eb..a0387b7b 100644
--- a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
+++ b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
@@ -25,8 +25,9 @@ TI_BIN_UNPK_CMDS=""
TI_BIN_UNPK_ARGS="--prefix ${S} --mode silent"
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${CG_XML_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE}
}
FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}"