aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gdbc6x/gdbc6x_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/gdbc6x/gdbc6x_git.bb')
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-devtools/gdbc6x/gdbc6x_git.bb b/recipes-devtools/gdbc6x/gdbc6x_git.bb
index 0e6a907c..820e1d01 100644
--- a/recipes-devtools/gdbc6x/gdbc6x_git.bb
+++ b/recipes-devtools/gdbc6x/gdbc6x_git.bb
@@ -5,10 +5,18 @@ LIC_FILES_CHKSUM = "file://debian/copyright;md5=bf0fe2872eb3dfeebb2cbe38206fe81f
DEPENDS = "ncurses bison texinfo flex gettext"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI_append = " \
file://init \
+ file://0001-coffgen.c-adjust-fall-through-comment-to-work-with-g.patch;striplevel=2 \
+ file://0001-reloc.c-add-comments-for-implicit-fallthrough-error-.patch;striplevel=2 \
+ file://0001-srec.c-fix-implicit-fallthrough-and-format-overflow-.patch;striplevel=2 \
+ file://0001-ihex.c-fix-format-overflow-error-in-gcc7.patch;striplevel=2 \
+ file://0001-elf32-tic6x.c-fix-implicit-fallthrough-error-in-gcc7.patch;striplevel=2 \
+ file://0001-elf.c-correct-fallthrough-comment-to-recognize-by-gc.patch;striplevel=2 \
+ file://0001-elflink.c-fix-implicit-fallthrough-error-in-gcc7.patch;striplevel=2 \
+ file://0001-tic6x-dis.c-fix-format-truncation-and-implicit-fallt.patch;striplevel=2 \
"
S = "${WORKDIR}/git/gdbc6x"
@@ -34,7 +42,7 @@ do_install () {
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/gdbserverproxy
}
-RDEPENDS_${PN} = "gdbserverproxy-module-drv"
+RDEPENDS_${PN} = "gdbserverproxy-module-drv bash"
include gdbc6x.inc