aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw_5.2.7.bb37
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw_git.bb47
2 files changed, 37 insertions, 47 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw_5.2.7.bb b/recipes-bsp/prueth-fw/prueth-fw_5.2.7.bb
new file mode 100644
index 00000000..2840b2f1
--- /dev/null
+++ b/recipes-bsp/prueth-fw/prueth-fw_5.2.7.bb
@@ -0,0 +1,37 @@
+SUMMARY = "PRU Ethernet firmware for AM57xx, AM437x and AM335x"
+
+LICENSE = "TI-TFL"
+LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
+
+PR = "r0"
+
+CLEANBROKEN = "1"
+
+COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRCREV = "7ba9722b74608ad4472790972917e1205eb3c049"
+BRANCH ?= "ti-linux-firmware"
+
+SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
+
+S = "${WORKDIR}/git"
+
+TARGET = ""
+TARGET_ti33x = "am335x-pru0-prueth-fw.elf am335x-pru1-prueth-fw.elf"
+TARGET_ti43x = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf"
+TARGET_am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
+TARGET_am57xx-hs-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware/ti-pruss
+ for f in ${TARGET}; do
+ install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
+ done
+}
+
+
+FILES_${PN} = "${base_libdir}/firmware"
+
+INSANE_SKIP_${PN} = "arch"
diff --git a/recipes-bsp/prueth-fw/prueth-fw_git.bb b/recipes-bsp/prueth-fw/prueth-fw_git.bb
deleted file mode 100644
index f7718ad2..00000000
--- a/recipes-bsp/prueth-fw/prueth-fw_git.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-DESCRIPTION = "PRU Ethernet firmware for AM57xx, AM437x, AM335x and K2G"
-
-require recipes-ti/includes/ti-paths.inc
-require recipes-bsp/icss-emac-lld/icss-emac-lld.inc
-
-LICENSE = "TI-TFL"
-LIC_FILES_CHKSUM = "file://icss_dualemac/src/firmware_version.h;beginline=6;endline=53;md5=1f0a640a261059cdcbbcf01e6a739ff3"
-
-PR = "${INC_PR}.0"
-
-TI_PDK_COMP = "ti.drv.icss_emac.firmware"
-
-B = "${S}/icss_dualemac"
-
-COMPATIBLE_MACHINE = "am57xx-evm|am57xx-hs-evm|ti43x|ti33x|k2g"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS = "ti-cgt-pru-native"
-
-PRU_VERSION = ""
-PRU_VERSION_ti33x = "REV1"
-PRU_VERSION_ti43x = "REV1"
-PRU_VERSION_am57xx-evm = "REV2"
-PRU_VERSION_am57xx-hs-evm = "REV2"
-PRU_VERSION_k2g = "REV2"
-
-FW_PREFIX = ""
-FW_PREFIX_ti33x = "am335x"
-FW_PREFIX_ti43x = "am437x"
-FW_PREFIX_am57xx-evm = "am57xx"
-FW_PREFIX_am57xx-hs-evm = "am57xx"
-FW_PREFIX_k2g = "k2g"
-
-EXTRA_OEMAKE += "CL_PRU_INSTALL_PATH="${TI_CGT_PRU_INSTALL_DIR}" PRU_VERSION_LIST="${PRU_VERSION}""
-
-do_install() {
- install -d ${D}${base_libdir}/firmware/ti-pruss
- install -m 0644 ./elf/${PRU_VERSION}/icss_dualemac_PRU0.elf \
- ${D}${base_libdir}/firmware/ti-pruss/${FW_PREFIX}-pru0-prueth-fw.elf
- install -m 0644 ./elf/${PRU_VERSION}/icss_dualemac_PRU1.elf \
- ${D}${base_libdir}/firmware/ti-pruss/${FW_PREFIX}-pru1-prueth-fw.elf
-}
-
-FILES_${PN} = "${base_libdir}/firmware"
-
-INSANE_SKIP_${PN} = "arch"