aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/boot-monitor/boot-monitor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/boot-monitor/boot-monitor_git.bb')
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index 6e682138..6967be72 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -1,11 +1,5 @@
DESCRIPTION = "Boot Monitor - TI ARM Boot monitor code"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-
LICENSE = "BSD"
-
-BOOT_MONITOR_BINARY ?= "skern.bin"
-BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin"
-
LIC_FILES_CHKSUM = "file://COPYING;md5=25fe219a6febf6e5bb45beda1b2eb315"
COMPATIBLE_MACHINE = "keystone"
@@ -22,6 +16,13 @@ S = "${WORKDIR}/git"
#Tag "K2_BM_14.05"
SRCREV = "0e3ffe1ea4a0cee38ae2406901b7cf4d5324b5e9"
+BOOT_MONITOR_BINARY ?= "skern.bin"
+BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin"
+
+FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}""
+
do_compile () {
unset LDFLAGS
unset CFLAGS