aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc3
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc16
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb8
-rw-r--r--recipes-ti/ipc/ti-ipc.inc6
5 files changed, 26 insertions, 9 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 7f938428..6aea8e64 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,4 +1,4 @@
-PV = "3.47.02.00"
+PV = "3.50.01.00"
INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -13,6 +13,7 @@ PLATFORM_k2g = "66AK2G"
PLATFORM_omapl138 = "OMAPL138"
PLATFORM_c667x-evm = "C6678"
PLATFORM_c665x-evm = "C6678"
+PLATFORM_am65xx-evm = "AM65XX"
ALT_PLATFORM_k2hk = "TCI6636"
ALT_PLATFORM_am57xx-evm = "AM572X AM571X"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
index cd2240cd..022b13f0 100644
--- a/recipes-ti/ipc/ti-ipc-examples.inc
+++ b/recipes-ti/ipc/ti-ipc-examples.inc
@@ -3,7 +3,7 @@ require ti-ipc-common.inc
require ti-ipc-rtos.inc
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02"
+LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=a52324bd5033bb49ea07bade1244ac9a"
INSANE_SKIP_${PN} += "arch"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 868743e6..13b19146 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
branch=${TI_IPC_METADATA_GIT_BRANCH};\
name=${TI_IPC_METADATA_NAME}"
-# Corresponds to tag: 3.47.02.00
-SRCREV_ipc-metadata = "e8aff83111b8a0d64d7a77413b6f66d3106084d8"
+# Corresponds to tag: 3.50.01.00
+SRCREV_ipc-metadata = "19a8e70cf6ca4fe0984987e25d937c61a62c7658"
-# Corresponds to tag: 3.47.02.00
-SRCREV_ipc-examples = "351e9a6d94c68f7ff64b2c002ee6750242ece6d9"
+# Corresponds to tag: 3.50.01.00
+SRCREV_ipc-examples = "1975687076426b587be8d2530df56c24425ca53a"
S_ipc-examples = "${WORKDIR}/git/ipc-examples"
S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
@@ -50,6 +50,9 @@ DEPENDS_append_omapl138 = " ti-cgt6x-native \
DEPENDS_append_c66x = " ti-cgt6x-native \
"
+DEPENDS_append_am65xx-evm = " ti-cgt-arm-native \
+ gcc-linaro-baremetal-aarch64-native"
+
IPC_TARGETS = ""
IPC_TARGETS_omap-a15 = "\
@@ -73,6 +76,11 @@ IPC_TARGETS_c66x = " \
ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
"
+IPC_TARGETS_am65xx-evm = "\
+ gnu.targets.arm.A53F="${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN}" \
+ ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \
+"
+
EXTRA_OEMAKE = "\
PLATFORM=${PLATFORM} \
XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index b292d677..c374bb1f 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -122,3 +122,11 @@ pkg_postinst_${PN}-fw_omapl138 () {
pkg_postrm_${PN}-fw_omapl138 () {
update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674
}
+
+pkg_postinst_${PN}-fw_am65xx-evm () {
+ update-alternatives --install /lib/firmware/am65x-mcu-r5f0-fw am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X/messageq_single.xer5f ${ALTERNATIVE_PRIORITY}
+}
+
+pkg_postrm_${PN}-fw_am65xx-evm () {
+ update-alternatives --remove am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X/messageq_single.xe674
+}
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index e8038a56..b10e242a 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
TI_IPC_GIT_PROTOCOL = "git"
-TI_IPC_GIT_BRANCH = "3.47"
+TI_IPC_GIT_BRANCH = "3.50"
-#Corresponds to 3.47.02.00
-TI_IPC_SRCREV = "24c36385d096613af123d1e1696fb2fee652ef36"
+#Corresponds to 3.50.01.00C
+TI_IPC_SRCREV = "32294eb80e9889ba12d0c008b21acab4545713af"
BRANCH = "${TI_IPC_GIT_BRANCH}"
SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"