aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/ti-pdk.bbclass2
-rw-r--r--recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb5
-rw-r--r--recipes-ti/bios/ti-sysbios.inc3
-rw-r--r--recipes-ti/devtools/ti-cg-xml_2.41.00.bb3
-rw-r--r--recipes-ti/dsplib/dsplib-c66x.inc3
-rw-r--r--recipes-ti/framework-components/ti-framework-components.inc3
-rw-r--r--recipes-ti/imglib/imglib-c66x.inc3
-rw-r--r--recipes-ti/mathlib/mathlib-c66x.inc3
-rw-r--r--recipes-ti/xdais/ti-xdais.inc3
9 files changed, 18 insertions, 10 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index eca3652c..981ec12e 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -89,7 +89,7 @@ do_compile() {
do_install () {
install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages
- find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \;
+ find -name "*.tar" -exec tar xf {} --no-same-owner -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \;
if [ "${PDK_COMP_LINK_TEXT}" != "" ]
then
diff --git a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
index ce9ef855..7fd778a4 100644
--- a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
+++ b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
@@ -2,7 +2,7 @@ require edma3-lld.inc
require recipes-ti/includes/ti-paths.inc
require recipes-ti/includes/ti-staging.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native"
@@ -106,8 +106,9 @@ do_compile () {
}
do_install () {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE}
}
INSANE_SKIP_${PN}-dev = "arch ldflags"
diff --git a/recipes-ti/bios/ti-sysbios.inc b/recipes-ti/bios/ti-sysbios.inc
index 408be783..53b55a52 100644
--- a/recipes-ti/bios/ti-sysbios.inc
+++ b/recipes-ti/bios/ti-sysbios.inc
@@ -15,8 +15,9 @@ BINFILE="bios_setuplinux_${PV}.bin"
TI_BIN_UNPK_CMDS="Y: q:workdir:Y"
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${SYSBIOS_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE}
}
ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
index 115254eb..a0387b7b 100644
--- a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
+++ b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
@@ -25,8 +25,9 @@ TI_BIN_UNPK_CMDS=""
TI_BIN_UNPK_ARGS="--prefix ${S} --mode silent"
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${CG_XML_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE}
}
FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/dsplib/dsplib-c66x.inc b/recipes-ti/dsplib/dsplib-c66x.inc
index 31acc1e8..ce978dbd 100644
--- a/recipes-ti/dsplib/dsplib-c66x.inc
+++ b/recipes-ti/dsplib/dsplib-c66x.inc
@@ -16,8 +16,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
TI_BIN_UNPK_CMDS = ""
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE}
}
ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/framework-components/ti-framework-components.inc b/recipes-ti/framework-components/ti-framework-components.inc
index e111ec45..d3a1d758 100644
--- a/recipes-ti/framework-components/ti-framework-components.inc
+++ b/recipes-ti/framework-components/ti-framework-components.inc
@@ -11,8 +11,9 @@ S = "${WORKDIR}/framework_components_${PV}"
SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball"
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${FC_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${FC_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${FC_INSTALL_DIR_RECIPE}
}
INSANE_SKIP_${PN} = "ldflags"
diff --git a/recipes-ti/imglib/imglib-c66x.inc b/recipes-ti/imglib/imglib-c66x.inc
index 3c76ad5e..eb575985 100644
--- a/recipes-ti/imglib/imglib-c66x.inc
+++ b/recipes-ti/imglib/imglib-c66x.inc
@@ -18,8 +18,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
TI_BIN_UNPK_CMDS = ""
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE}
}
ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/mathlib/mathlib-c66x.inc b/recipes-ti/mathlib/mathlib-c66x.inc
index 1511337e..7951e6ca 100644
--- a/recipes-ti/mathlib/mathlib-c66x.inc
+++ b/recipes-ti/mathlib/mathlib-c66x.inc
@@ -18,8 +18,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
TI_BIN_UNPK_CMDS = ""
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE}
}
ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/xdais/ti-xdais.inc b/recipes-ti/xdais/ti-xdais.inc
index a12ad640..24268b3a 100644
--- a/recipes-ti/xdais/ti-xdais.inc
+++ b/recipes-ti/xdais/ti-xdais.inc
@@ -11,8 +11,9 @@ S = "${WORKDIR}/xdais_${PV}"
SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/xdais/${PV}/exports/xdais_${PV}.tar.gz;name=xdaistarball"
do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
install -d ${D}${XDAIS_INSTALL_DIR_RECIPE}
- cp -pPrf ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE}
}
INHIBIT_PACKAGE_STRIP = "1"