aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch56
-rw-r--r--recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb9
2 files changed, 4 insertions, 61 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch b/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch
deleted file mode 100644
index 4dc219cd..00000000
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From dbdbd9309a58ee723fc827ef5fd45c28347cf61f Mon Sep 17 00:00:00 2001
-From: Eric Ruei <e-ruei1@ti.com>
-Date: Tue, 7 May 2019 17:06:09 -0400
-Subject: [PATCH] km: support general toolchain
-
-This is a patch from IMG to support general toolchains such as
-aarch64-oe-linux-gnu, aarch64-poky-linux-gnu, arm-none-linux-gnueabi
-per IMG ticket 122059
-
-Signed-off-by: Eric Ruei <e-ruei1@ti.com>
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- build/linux/config/compiler.mk | 12 +++++++++++-
- .../build/linux/config/compilers/arm-linux-gnueabi.mk | 6 ++++++
- 2 files changed, 17 insertions(+), 1 deletion(-)
- create mode 100644 build/linux/config/compilers/arm-linux-gnueabi.mk
-
-diff --git a/build/linux/config/compiler.mk b/build/linux/config/compiler.mk
-index 82c9d44..dead2f9 100644
---- a/build/linux/config/compiler.mk
-+++ b/build/linux/config/compiler.mk
-@@ -48,13 +48,14 @@ define calculate-compiler-preferred-target
- ifeq ($(2),qcc)
- $(1)_compiler_preferred_target := qcc
- else
-- $(1)_compiler_preferred_target := $$(subst --,-,$$(shell $(2) -dumpmachine))
-+ $(1)_compiler_preferred_target := $$(subst --,-,$$(subst unknown,,$$(shell $(2) -dumpmachine)))
- ifeq ($$($(1)_compiler_preferred_target),)
- $$(warning No output from '$(2) -dumpmachine')
- $$(warning Check that the compiler is in your PATH and CROSS_COMPILE is)
- $$(warning set correctly.)
- $$(error Unable to run compiler '$(2)')
- endif
-+ $$(warning $(1) $(2))
- ifneq ($$(filter %-w64-mingw32,$$($(1)_compiler_preferred_target)),)
- # Use the compiler target name.
- else
-@@ -64,6 +65,15 @@ define calculate-compiler-preferred-target
- ifneq ($$(filter arm-linux-android,$$($(1)_compiler_preferred_target)),)
- $(1)_compiler_preferred_target := arm-linux-androideabi
- endif
-+ ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
-+ $(1)_compiler_preferred_target := aarch64-linux-gnu
-+ endif
-+ ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
-+ $(1)_compiler_preferred_target := arm-linux-gnueabi
-+ endif
-+ ifneq ($$(filter arm-%-gnueabihf,$$($(1)_compiler_preferred_target)),)
-+ $(1)_compiler_preferred_target := arm-linux-gnueabihf
-+ endif
- ifneq ($$(filter clang%,$(2)),)
- ifeq ($(1),target)
- ifeq (arm-linux-gnueabihf,$$(CROSS_TRIPLE))
---
-2.7.4
-
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
index da4ec6e6..e0632a18 100644
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
@@ -7,7 +7,7 @@ inherit module features_check
REQUIRED_MACHINE_FEATURES = "gpu"
-MACHINE_KERNEL_PR_append = "f"
+MACHINE_KERNEL_PR_append = "g"
PR = "${MACHINE_KERNEL_PR}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -19,12 +19,11 @@ PROVIDES = "virtual/gpudriver"
BRANCH = "linuxws/zeus/k5.4/${PV}"
-SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \
- file://0001-km-support-general-toolchain.patch \
-"
+SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH}"
+
S = "${WORKDIR}/git"
-SRCREV = "e0bc128ee5098e30c9fb096634ba6bec01b5fc17"
+SRCREV = "f58bea1084c5004f129943a53b94ee1446e9c3a7"
PVR_SOC = "j721e_linux"
PVR_BVNC = "22.104.208.318"