aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/hplib/hplib-test_git.bb2
-rw-r--r--recipes-bsp/hplib/hplib.inc13
-rw-r--r--recipes-bsp/hplib/hplib_git.bb2
3 files changed, 14 insertions, 3 deletions
diff --git a/recipes-bsp/hplib/hplib-test_git.bb b/recipes-bsp/hplib/hplib-test_git.bb
index 574fa2a7..4ba79dbd 100644
--- a/recipes-bsp/hplib/hplib-test_git.bb
+++ b/recipes-bsp/hplib/hplib-test_git.bb
@@ -6,6 +6,8 @@ DEPENDS = "common-csl-ip qmss-lld sa-lld pktlib hplib"
include hplib.inc
+PR = "${INC_PR}.0"
+
CHOICELIST = "yes no"
S = "${WORKDIR}/git/ti/runtime/hplib"
diff --git a/recipes-bsp/hplib/hplib.inc b/recipes-bsp/hplib/hplib.inc
index e4211ee0..7ed47a56 100644
--- a/recipes-bsp/hplib/hplib.inc
+++ b/recipes-bsp/hplib/hplib.inc
@@ -2,9 +2,16 @@ COMPATIBLE_MACHINE = "keystone"
DEVICELIST = "k2h k2k k2l k2e"
-BRANCH = "master"
-SRC_URI = "git://git.ti.com/keystone-rtos/hplib.git;protocol=git;branch=${BRANCH}"
+HPLIB_GIT_URI = "git://git.ti.com/keystone-rtos/hplib.git"
+HPLIB_GIT_PROTOCOL = "git"
+HPLIB_GIT_BRANCH = "master"
# Below Commit ID corresponds to "DEV.HPLIB.01.01.00.06"
-SRCREV = "1cbe6a41926c131d9cab63b40d43807c6e56e2fd"
+HPLIB_SRCREV = "1cbe6a41926c131d9cab63b40d43807c6e56e2fd"
+
+BRANCH = "${HPLIB_GIT_BRANCH}"
+SRC_URI = "${HPLIB_GIT_URI};protocol=${HPLIB_GIT_PROTOCOL};branch=${BRANCH}"
+SRCREV = "${HPLIB_SRCREV}"
+
PV = "01.01.00.06+git${SRCPV}"
+INC_PR = "r1"
diff --git a/recipes-bsp/hplib/hplib_git.bb b/recipes-bsp/hplib/hplib_git.bb
index da8853bd..1423de5b 100644
--- a/recipes-bsp/hplib/hplib_git.bb
+++ b/recipes-bsp/hplib/hplib_git.bb
@@ -7,6 +7,8 @@ RDEPENDS_${PN} = "hplib-mod"
include hplib.inc
+PR = "${INC_PR}.0"
+
CHOICELIST = "yes no"
S = "${WORKDIR}/git/ti/runtime/hplib"