aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc9
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux_git.bb48
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc31
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb70
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc26
-rw-r--r--recipes-ti/ipc/ti-ipc.inc6
6 files changed, 122 insertions, 68 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 6aa08c53..2fb7ffbc 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,4 +1,4 @@
-PV = "3.45.00.00"
+PV = "3.47.00.00"
INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -6,9 +6,12 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
PLATFORM = "UNKNOWN"
PLATFORM_omap5-evm = "OMAP54XX"
PLATFORM_dra7xx = "DRA7XX"
-PLATFORM_k2hk-evm = "TCI6638"
+PLATFORM_k2hk = "TCI6638"
PLATFORM_k2l-evm = "TCI6630"
PLATFORM_k2e = "66AK2E"
PLATFORM_k2g = "66AK2G"
+PLATFORM_omapl138 = "OMAPL138"
+PLATFORM_c667x-evm = "C6678"
+PLATFORM_c665x-evm = "C6678"
-ALT_PLATFORM_k2hk-evm = "TCI6636"
+ALT_PLATFORM_k2hk = "TCI6636"
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
new file mode 100644
index 00000000..2340206c
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
+require ti-ipc-examples.inc
+
+DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos"
+
+do_compile_append() {
+
+ if [ "${PLATFORM}" != "UNKNOWN" ]; then
+ oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+ fi
+ oe_runmake -C examples all HOSTOS="linux" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake -C examples all HOSTOS="linux" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ PLATFORM="${ALT_PLATFORM}"
+ fi
+ fi
+}
+
+do_install_append() {
+ cd ${S_ipc-examples}/src
+ IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
+
+ if [ "${PLATFORM}" != "UNKNOWN" ]; then
+ # Install directory for linux examples
+ install -d ${D}${bindir}/ipc/examples
+ oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
+ HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
+ PLATFORM="${ALT_PLATFORM}"
+ fi
+ fi
+}
+
+FILES_${PN} += "${bindir}/*"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
new file mode 100644
index 00000000..c9fe2cbc
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc-examples.inc
@@ -0,0 +1,31 @@
+HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC"
+require ti-ipc-common.inc
+require ti-ipc-rtos.inc
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02"
+
+INSANE_SKIP_${PN} += "arch"
+
+ALLOW_EMPTY_${PN} = "1"
+
+IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
+
+do_compile() {
+
+ cd ${S_ipc-examples}/src
+ oe_runmake .examples \
+ IPCTOOLS="${S_ipc-metadata}/src/etc"
+
+ if [ ! -z ${ALT_PLATFORM} ]; then
+ oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \
+ IPCTOOLS="${S_ipc-metadata}/src/etc"
+ fi
+}
+
+do_install() {
+ cd ${S_ipc-examples}/src
+ IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
+}
+
+INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 019bffac..5482ce41 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -1,83 +1,41 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) examples"
-HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
-require ti-ipc-common.inc
-require ti-ipc-rtos.inc
+DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
+require ti-ipc-examples.inc
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02"
+DEPENDS = "ti-xdctools ti-sysbios ti-ipc-rtos"
-DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos"
+do_compile_append() {
-INSANE_SKIP_${PN} += "arch"
-
-ALLOW_EMPTY_${PN} = "1"
-
-IPC_INSTALL_DIR="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
-
-do_compile() {
-
- cd ${S_ipc-examples}/src
- oe_runmake .examples \
- IPCTOOLS="${S_ipc-metadata}/src/etc"
-
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \
- IPCTOOLS="${S_ipc-metadata}/src/etc"
- echo test
- fi
if [ "${PLATFORM}" != "UNKNOWN" ]; then
oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
if [ ! -z ${ALT_PLATFORM} ]; then
oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \
IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
fi
oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
if [ ! -z ${ALT_PLATFORM} ]; then
oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- PLATFORM="${ALT_PLATFORM}"
- echo testing
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
fi
fi
}
-do_install() {
- cd ${S_ipc-examples}/src
- IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
-
- install -d ${D}/ipc_${IPC_VERSION}/examples
+do_install_append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
+ # Install directory for bios examples
+ install -d ${D}/ipc_${IPC_VERSION}/examples/bios
oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples"
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples"
-
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples"
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \
+ oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
PLATFORM="${ALT_PLATFORM}"
oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \
- PLATFORM="${ALT_PLATFORM}"
-
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
PLATFORM="${ALT_PLATFORM}"
fi
fi
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 696a8971..57cd1325 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -1,5 +1,4 @@
require recipes-ti/includes/ti-paths.inc
-require recipes-ti/includes/ti-staging.inc
TI_IPC_EXAMPLES_GIT_URI = "git://git.ti.com/ipc/ipc-examples.git"
TI_IPC_EXAMPLES_DEST_SUFFIX = "git/ipc-examples"
@@ -25,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
branch=${TI_IPC_METADATA_GIT_BRANCH};\
name=${TI_IPC_METADATA_NAME}"
-# Corresponds to tag: 3.45.00.00
-SRCREV_ipc-examples = "3a8ee1841ec36117a9bcd3d45bb2781bbd53ecf8"
+# Corresponds to tag: 3.47.00.00
+SRCREV_ipc-examples = "e71b82187a324faa9394b83e39495be38255f05b"
-# Corresponds to tag: 3.45.00.00
-SRCREV_ipc-metadata = "30b83f09be1877f86b22c971d978cb478fc7dd6e"
+# Corresponds to tag: 3.47.00.00
+SRCREV_ipc-metadata = "f026a364d0b9c1aba5c695bf0aac0be8ede95f59"
S_ipc-examples = "${WORKDIR}/git/ipc-examples"
S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
@@ -37,7 +36,7 @@ S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
RELEASE_TYPE = "GA"
RELEASE_SUFFIX = ""
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.r2"
DEPENDS_append_keystone = " ti-cgt6x-native \
gcc-arm-none-eabi-native \
@@ -46,7 +45,13 @@ DEPENDS_append_omap-a15 = " ti-cgt6x-native \
ti-cgt-arm-native \
gcc-arm-none-eabi-native \
"
+DEPENDS_append_omapl138 = " ti-cgt6x-native \
+"
+DEPENDS_append_c66x = " ti-cgt6x-native \
+"
+
IPC_TARGETS = ""
+
IPC_TARGETS_omap-a15 = "\
gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
@@ -54,11 +59,19 @@ IPC_TARGETS_omap-a15 = "\
ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
"
+IPC_TARGETS_omapl138 = "\
+ ti.targets.elf.C674="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
+"
+
IPC_TARGETS_keystone = " \
gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
"
+IPC_TARGETS_c66x = " \
+ ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
+ ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
+"
EXTRA_OEMAKE = "\
PLATFORM=${PLATFORM} \
@@ -66,4 +79,5 @@ EXTRA_OEMAKE = "\
BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \
${IPC_TARGETS} \
JOBS="--jobs=${BB_NUMBER_THREADS}" \
+ JAVA_TOOL_OPTIONS=-Xss2560k \
"
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index ea256d24..02f3c8d3 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
TI_IPC_GIT_PROTOCOL = "git"
-TI_IPC_GIT_BRANCH = "master"
+TI_IPC_GIT_BRANCH = "3.47"
-#Corresponds to 3.45.00.00
-TI_IPC_SRCREV = "1584985938884bf6cb1d839779578354b1865ea4"
+#Corresponds to 3.47.00.00
+TI_IPC_SRCREV = "e576990e3a220ad394b287588c1c7e85e8644d23"
BRANCH = "${TI_IPC_GIT_BRANCH}"
SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"