aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demo/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demo/recipes-devtools')
-rw-r--r--meta-demo/recipes-devtools/python/python-google-cloud-bigtable.inc16
-rw-r--r--meta-demo/recipes-devtools/python/python3-google-cloud-bigtable_0.32.1.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-demo/recipes-devtools/python/python-google-cloud-bigtable.inc b/meta-demo/recipes-devtools/python/python-google-cloud-bigtable.inc
new file mode 100644
index 0000000..d123166
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-google-cloud-bigtable.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Google Cloud Bigtable API client library"
+HOMEPAGE = "https://github.com/googleapis/google-cloud-python"
+DESCRIPTION = "Google Cloud Bigtable is Google’s NoSQL Big Data database service. \
+It’s the same database that powers many core Google services, \
+including Search, Analytics, Maps, and Gmail."
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit pypi
+
+SRC_URI[md5sum] = "5dfda326b1beea64227e41f5c7ceec1b"
+SRC_URI[sha256sum] = "bb113894e1322102d4917740be4870798cad76aa4291ff742ada5548988b2223"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-demo/recipes-devtools/python/python3-google-cloud-bigtable_0.32.1.bb b/meta-demo/recipes-devtools/python/python3-google-cloud-bigtable_0.32.1.bb
new file mode 100644
index 0000000..2279d1c
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python3-google-cloud-bigtable_0.32.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-google-cloud-bigtable.inc