aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demo/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demo/recipes-devtools')
-rw-r--r--meta-demo/recipes-devtools/python/python-cachetools.inc16
-rw-r--r--meta-demo/recipes-devtools/python/python-cachetools_3.1.0.bb2
-rw-r--r--meta-demo/recipes-devtools/python/python3-cachetools_3.1.0.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-demo/recipes-devtools/python/python-cachetools.inc b/meta-demo/recipes-devtools/python/python-cachetools.inc
new file mode 100644
index 0000000..52ae318
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-cachetools.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Extensible memoizing collections and decorators"
+HOMEPAGE = "https://github.com/tkem/cachetools"
+DESCRIPTION = "This module provides various memoizing \
+collections and decorators, including variants of the \
+Python 3 Standard Library @lru_cache function decorator."
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5"
+
+inherit pypi
+
+SRC_URI[md5sum] = "a7b1c5eb5390d50067c62d7bcb4e875c"
+SRC_URI[sha256sum] = "9efcc9fab3b49ab833475702b55edd5ae07af1af7a4c627678980b45e459c460"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-demo/recipes-devtools/python/python-cachetools_3.1.0.bb b/meta-demo/recipes-devtools/python/python-cachetools_3.1.0.bb
new file mode 100644
index 0000000..8c12ad0
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-cachetools_3.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-cachetools.inc
diff --git a/meta-demo/recipes-devtools/python/python3-cachetools_3.1.0.bb b/meta-demo/recipes-devtools/python/python3-cachetools_3.1.0.bb
new file mode 100644
index 0000000..76b2f67
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python3-cachetools_3.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-cachetools.inc