aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demo/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demo/recipes-devtools/python')
-rw-r--r--meta-demo/recipes-devtools/python/python-flask-socketio.inc18
-rw-r--r--meta-demo/recipes-devtools/python/python-flask-socketio_3.3.2.bb2
-rw-r--r--meta-demo/recipes-devtools/python/python3-flask-socketio_3.3.2.bb2
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-demo/recipes-devtools/python/python-flask-socketio.inc b/meta-demo/recipes-devtools/python/python-flask-socketio.inc
new file mode 100644
index 0000000..251d13e
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-flask-socketio.inc
@@ -0,0 +1,18 @@
+SUMMARY = "Socket.IO integration for Flask applications"
+HOMEPAGE = "https://github.com/miguelgrinberg/Flask-SocketIO/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=38cc21254909604298ce763a6e4440a0"
+
+inherit pypi
+
+PYPI_PACKAGE = "Flask-SocketIO"
+
+SRC_URI[md5sum] = "298965a43f6534e8a5b24d1ba1fc4186"
+SRC_URI[sha256sum] = "8d8f9f104db5ddff1b06ba322d8e158881d590144199c993fe26cf53218c7edd"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-flask \
+ ${PYTHON_PN}-socketio \
+ "
diff --git a/meta-demo/recipes-devtools/python/python-flask-socketio_3.3.2.bb b/meta-demo/recipes-devtools/python/python-flask-socketio_3.3.2.bb
new file mode 100644
index 0000000..3b9ad33
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-flask-socketio_3.3.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-flask-socketio.inc
diff --git a/meta-demo/recipes-devtools/python/python3-flask-socketio_3.3.2.bb b/meta-demo/recipes-devtools/python/python3-flask-socketio_3.3.2.bb
new file mode 100644
index 0000000..ffc4aa7
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python3-flask-socketio_3.3.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-flask-socketio.inc