aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demo/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demo/recipes-devtools/python')
-rw-r--r--meta-demo/recipes-devtools/python/python-engineio.inc13
-rw-r--r--meta-demo/recipes-devtools/python/python-engineio_3.5.0.bb2
-rw-r--r--meta-demo/recipes-devtools/python/python3-engineio_3.5.0.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-demo/recipes-devtools/python/python-engineio.inc b/meta-demo/recipes-devtools/python/python-engineio.inc
new file mode 100644
index 0000000..c399d7d
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-engineio.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Engine.IO server"
+HOMEPAGE = "https://github.com/miguelgrinberg/python-engineio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+inherit pypi
+
+PYPI_PACKAGE = "python-engineio"
+
+SRC_URI[md5sum] = "011a61f1ee84755043cf862c8cc24f21"
+SRC_URI[sha256sum] = "b2756ce53076163eb24f59c1d1a903ac72f071ad4fb7b3ef6dab1b1b9ae9a44f"
diff --git a/meta-demo/recipes-devtools/python/python-engineio_3.5.0.bb b/meta-demo/recipes-devtools/python/python-engineio_3.5.0.bb
new file mode 100644
index 0000000..7dd6ec0
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-engineio_3.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-engineio.inc
diff --git a/meta-demo/recipes-devtools/python/python3-engineio_3.5.0.bb b/meta-demo/recipes-devtools/python/python3-engineio_3.5.0.bb
new file mode 100644
index 0000000..028d110
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python3-engineio_3.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-engineio.inc