aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demo/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demo/recipes-devtools/python')
-rw-r--r--meta-demo/recipes-devtools/python/python-google-auth.inc15
-rw-r--r--meta-demo/recipes-devtools/python/python3-google-auth_1.6.3.bb2
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-demo/recipes-devtools/python/python-google-auth.inc b/meta-demo/recipes-devtools/python/python-google-auth.inc
new file mode 100644
index 0000000..61e37c0
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-google-auth.inc
@@ -0,0 +1,15 @@
+SUMMARY = "Google Authentication Library"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
+DESCRIPTION = "This library simplifies using Google’s various \
+server-to-server authentication mechanisms to access Google APIs."
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit pypi
+
+SRC_URI[md5sum] = "0440718247cc4531422e2a8f4f012e8b"
+SRC_URI[sha256sum] = "0f7c6a64927d34c1a474da92cfc59e552a5d3b940d3266606c6a28b72888b9e4"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-demo/recipes-devtools/python/python3-google-auth_1.6.3.bb b/meta-demo/recipes-devtools/python/python3-google-auth_1.6.3.bb
new file mode 100644
index 0000000..0d86a65
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python3-google-auth_1.6.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-google-auth.inc