aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-demo/recipes-devtools/python/python-tqdm.inc13
-rw-r--r--meta-demo/recipes-devtools/python/python-tqdm_4.31.1.bb2
-rw-r--r--meta-demo/recipes-devtools/python/python3-tqdm_4.31.1.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-demo/recipes-devtools/python/python-tqdm.inc b/meta-demo/recipes-devtools/python/python-tqdm.inc
new file mode 100644
index 0000000..967a80c
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-tqdm.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Fast, Extensible Progress Meter"
+HOMEPAGE = "http://tqdm.github.io/"
+SECTION = "devel/python"
+
+LICENSE = "MIT & MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=054ef7105cba050017d1368262a1623c"
+
+inherit pypi
+
+SRC_URI[md5sum] = "807e8c13e16e3660ac88e05d711daeb0"
+SRC_URI[sha256sum] = "e22977e3ebe961f72362f6ddfb9197cc531c9737aaf5f607ef09740c849ecd05"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-demo/recipes-devtools/python/python-tqdm_4.31.1.bb b/meta-demo/recipes-devtools/python/python-tqdm_4.31.1.bb
new file mode 100644
index 0000000..b381009
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-tqdm_4.31.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-tqdm.inc
diff --git a/meta-demo/recipes-devtools/python/python3-tqdm_4.31.1.bb b/meta-demo/recipes-devtools/python/python3-tqdm_4.31.1.bb
new file mode 100644
index 0000000..348337f
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python3-tqdm_4.31.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-tqdm.inc