aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/bazel.bbclass5
-rw-r--r--recipes-devtools/bazel/bazel-native_0.21.0.bb3
2 files changed, 5 insertions, 3 deletions
diff --git a/classes/bazel.bbclass b/classes/bazel.bbclass
index 283043c..5d3a00a 100644
--- a/classes/bazel.bbclass
+++ b/classes/bazel.bbclass
@@ -63,6 +63,7 @@ def bazel_get_flags(d):
return flags
+TS_DL_DIR ??= "${DL_DIR}"
bazel_do_configure () {
cat > "${S}/bazelrc" <<-EOF
build --verbose_failures
@@ -77,8 +78,8 @@ build --host_linkopt=-Wl,--no-as-needed
build --strip=never
-fetch --distdir=${DL_DIR}
-build --distdir=${DL_DIR}
+fetch --distdir=${TS_DL_DIR}
+build --distdir=${TS_DL_DIR}
EOF
diff --git a/recipes-devtools/bazel/bazel-native_0.21.0.bb b/recipes-devtools/bazel/bazel-native_0.21.0.bb
index debc30c..b8d17a8 100644
--- a/recipes-devtools/bazel/bazel-native_0.21.0.bb
+++ b/recipes-devtools/bazel/bazel-native_0.21.0.bb
@@ -18,11 +18,12 @@ DEPENDS = "coreutils-native \
S="${WORKDIR}"
+TS_DL_DIR ??= "${DL_DIR}"
do_compile () {
export JAVA_HOME="${RECIPE_SYSROOT_NATIVE}/usr/lib/jvm/openjdk-8-native"
TMPDIR="${TOPDIR}/bazel" \
VERBOSE=yes \
- EXTRA_BAZEL_ARGS="--distdir=${DL_DIR}" \
+ EXTRA_BAZEL_ARGS="--distdir=${TS_DL_DIR}" \
./compile.sh
}