aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-demo/recipes-devtools/python/python-socketio.inc17
-rw-r--r--meta-demo/recipes-devtools/python/python-socketio_4.0.0.bb2
-rw-r--r--meta-demo/recipes-devtools/python/python3-socketio_4.0.0.bb2
3 files changed, 21 insertions, 0 deletions
diff --git a/meta-demo/recipes-devtools/python/python-socketio.inc b/meta-demo/recipes-devtools/python/python-socketio.inc
new file mode 100644
index 0000000..a23e780
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-socketio.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Socket.IO server"
+HOMEPAGE = "https://github.com/miguelgrinberg/python-socketio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+inherit pypi
+
+PYPI_PACKAGE = "python-socketio"
+
+SRC_URI[md5sum] = "0b57da61a9464d2e0dc9a8d0164d86d2"
+SRC_URI[sha256sum] = "64feb0817f1bf7e3e7fc05f6f65e28d76146d8061cb7de25b63502717f80e908"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-engineio \
+ "
diff --git a/meta-demo/recipes-devtools/python/python-socketio_4.0.0.bb b/meta-demo/recipes-devtools/python/python-socketio_4.0.0.bb
new file mode 100644
index 0000000..e25a6b3
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python-socketio_4.0.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-socketio.inc
diff --git a/meta-demo/recipes-devtools/python/python3-socketio_4.0.0.bb b/meta-demo/recipes-devtools/python/python3-socketio_4.0.0.bb
new file mode 100644
index 0000000..ce83d09
--- /dev/null
+++ b/meta-demo/recipes-devtools/python/python3-socketio_4.0.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-socketio.inc