summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/iotools/iotools_1.5.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-devtools/iotools/iotools_1.5.bb b/recipes-devtools/iotools/iotools_1.5.bb
index 187dc94..ba6701e 100644
--- a/recipes-devtools/iotools/iotools_1.5.bb
+++ b/recipes-devtools/iotools/iotools_1.5.bb
@@ -14,4 +14,8 @@ CFLAGS += ' -static -D_GNU_SOURCE -DVER_MAJOR=1 -DVER_MINOR=5'
do_install () {
install -d ${D}${sbindir}
oe_runmake SBINDIR=${D}${sbindir} install
+ #The Makefile installs files with "cp -a" which preserves ownership
+ #of user running bitbake resulting in QA Issue "host-user-contaminated"
+ #Fixup permissions
+ chown -R root:root ${D}${sbindir}
}